Revert "ar71xx: Clear bits in ath79_setup_qca955x_eth_cfg"
[openwrt.git] / target / linux / adm5120 / Makefile
index e97a80a..419c534 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,16 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-#LINUX_VERSION:=2.6.25.12
-LINUX_VERSION:=2.6.26
-SUBTARGETS:=router_le router_be
+FEATURES:=low_mem
+SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
+KERNEL_PATCHVER:=3.18
+
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
-DEFAULT_PACKAGES += \
-       kmod-input-core \
-       kmod-input-polldev \
-       kmod-input-gpio-buttons \
-       kmod-button-hotplug
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-keys-polled kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
 $(eval $(call BuildTarget))