ar71xx: rename 'nand' subtarget to 'mikrotik'
[openwrt.git] / target / linux / Makefile
index d1b4d54..f7bbdff 100644 (file)
@@ -1,38 +1,13 @@
+# 
+# Copyright (C) 2006-2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
 
-define kernel_template
+export TARGET_BUILD=1
 
-$(1)/$(2)-clean:
-       $(MAKE) -C $(1) BOARD="$(2)" clean
-
-$(1)/$(2)-prepare:
-       $(MAKE) -C $(1) BOARD="$(2)" prepare
-
-$(1)/$(2)-compile:
-       $(MAKE) -C $(1) BOARD="$(2)" compile
-
-$(1)/$(2)-rebuild:
-       $(MAKE) -C $(1) BOARD="$(2)" rebuild
-
-$(1)/$(2)-install:
-       $(MAKE) -C $(1) BOARD="$(2)" install
-
-ifeq ($(BR2_LINUX_$(3)),y)
-clean: $(1)/$(2)-clean
-prepare: $(1)/$(2)-prepare
-compile: $(1)/$(2)-compile
-rebuild: $(1)/$(2)-rebuild
-install: $(1)/$(2)-install
-endif
-
-.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install
-endef
-
-prepare:
-compile:
-install:
-rebuild:
-clean:
-       rm -rf $(BUILD_DIR)/kernel
-
-$(eval $(call kernel_template,linux-2.4,brcm,2_4_BRCM))
+prereq clean download prepare compile install menuconfig nconfig oldconfig update refresh: FORCE
+       @+$(NO_TRACE_MAKE) -C $(BOARD) $@