use radio0 only on the 5312
[openwrt.git] / target / linux / Makefile
index af3e3bd..c15d819 100644 (file)
@@ -1,28 +1,14 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
 
-PKG_OS:=$(shell uname -s)
-PKG_CPU:=$(shell uname -m)
-
-define kernel_template
-ifeq ($(CONFIG_LINUX_$(3)),y)
-KERNEL:=$(1)
-BOARD:=$(2)
-endif
-endef
-
-$(eval $(call kernel_template,2.4,brcm,2_4_BRCM))
-$(eval $(call kernel_template,2.4,ar7,2_4_AR7))
-$(eval $(call kernel_template,2.4,x86,2_4_X86))
-$(eval $(call kernel_template,2.6,brcm,2_6_BRCM))
-$(eval $(call kernel_template,2.6,x86,2_6_X86))
-$(eval $(call kernel_template,2.4,ar531x,2_4_AR531X))
-$(eval $(call kernel_template,2.6,aruba,2_6_ARUBA))
-$(eval $(call kernel_template,2.6,au1000,2_6_AU1000))
-$(eval $(call kernel_template,2.6,xscale,2_6_XSCALE))
-$(eval $(call kernel_template,2.6,sibyte,2_6_SIBYTE))
-
-export BOARD
-export KERNEL
+download:
+       $(MAKE) -C $(BOARD)-$(KERNEL) download
 
 prepare:
        $(MAKE) -C $(BOARD)-$(KERNEL) prepare
@@ -32,10 +18,9 @@ compile:
 
 install:
        $(MAKE) -C $(BOARD)-$(KERNEL) install
-       $(MAKE) -C image/$(BOARD) install
        
+menuconfig:
+       $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
+
 clean:
        $(MAKE) -C $(BOARD)-$(KERNEL) clean
-
-image/%:
-       $(MAKE) -C image $(patsubst image/%,%,$@)