[PATCH 2/2] Send ipkg-make-index.sh output to stdout
[openwrt.git] / target / imagebuilder / files / Makefile
index 469c4a2..002274a 100644 (file)
@@ -42,6 +42,7 @@ Building images:
        make image PROFILE="<profilename>" # override the default target profile
        make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
        make image FILES="<path>" # include extra files from <path>
+       make image BIN_DIR="<path>" # alternative output directory for the images
 
 endef
 $(eval $(call shexport,Helptext))
@@ -111,7 +112,7 @@ package_index: FORCE
        @echo
        @echo Building package index...
        @mkdir -p $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR)/tmp
-       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
                gzip -9c Packages > Packages.gz \
        ) >/dev/null 2>/dev/null
        $(OPKG) update
@@ -157,7 +158,8 @@ image:
        $(MAKE) _call_image \
                $(if $(PROFILE),USER_PROFILE="$(PROFILE)") \
                $(if $(FILES),USER_FILES="$(FILES)") \
-               $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)"))
+               $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
+               $(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)"))
 
 .SILENT: help info image