[include] add remaining missing build prereq checks
[openwrt.git] / rules.mk
index 114b16c..b7bad1c 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -122,6 +122,10 @@ endif
 LIBRPC=-lrpc
 LIBRPC_DEPENDS=+librpc
 
+ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
+  LIB_SUFFIX:=64
+endif
+
 ifndef DUMP
   ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
     -include $(TOOLCHAIN_DIR)/info.mk
@@ -169,7 +173,6 @@ PKG_CONFIG:=$(STAGING_DIR_HOST)/bin/pkg-config
 export PKG_CONFIG
 
 HOSTCC:=gcc
-HOSTCC_NOCACHE:=$(HOSTCC)
 HOST_CFLAGS:=-O2 -I$(STAGING_DIR_HOST)/include
 HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib