procd: add a small script that handles config reloads until configd is ready
[openwrt.git] / rules.mk
index 61c45a0..2e9e20d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -81,7 +81,7 @@ ifdef CONFIG_HAS_SPE_FPU
 endif
 ifdef CONFIG_MIPS64_ABI
   ifneq ($(CONFIG_MIPS64_ABI_O32),y)
-     ARCH_SUFFIX:=$(ARCH_SUFFIX)_$(subst ",,$(CONFIG_MIPS64_ABI))
+     ARCH_SUFFIX:=$(ARCH_SUFFIX)_$(call qstrip,$(CONFIG_MIPS64_ABI))
   endif
 endif
 
@@ -207,6 +207,7 @@ KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 CP:=cp -fpR
 LN:=ln -sf
+XARGS:=xargs -r
 
 INSTALL_BIN:=install -m0755
 INSTALL_DIR:=install -d -m0755