prepare for the transition to linux 2.6.22 - make it possible to override the kernel...
[openwrt.git] / rules.mk
index a6188f4..1419f2f 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -83,7 +83,9 @@ TARGET_CONFIGURE_OPTS:= \
   CXX=$(TARGET_CROSS)g++ \
   RANLIB=$(TARGET_CROSS)ranlib \
   STRIP=$(TARGET_CROSS)strip \
-  OBJCOPY=$(TARGET_CROSS)objcopy
+  OBJCOPY=$(TARGET_CROSS)objcopy \
+       OBJDUMP=$(TARGET_CROSS)objdump \
+       SIZE=$(TARGET_CROSS)size
 
 # strip an entire directory
 RSTRIP:= \
@@ -130,7 +132,6 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-
 all:
 FORCE: ;
 .PHONY: FORCE