move ccache dir to staging_dir_arch (removing the staging dir will make the ccache...
[openwrt.git] / rules.mk
index eebc758..0ec5daf 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -60,7 +60,7 @@ CP:=cp -fpR
 
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(TOPDIR)/ccache_$(ARCH)
+  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
 endif