add dependencies from the NEEDS variable to ipkg/control
[openwrt.git] / rules.mk
index fb963ab..0e7dd2e 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -1,46 +1,41 @@
+ifeq ($(DUMP),)
 include $(TOPDIR)/.config
+endif
+
 SHELL=/bin/bash
 export SHELL
 
-ifeq ($(V),)
-V=99
+ifdef V
+  ifeq ("$(origin V)", "command line")
+    KBUILD_VERBOSE = $(V)
+  endif
 endif
-
-
-ifneq ($(V),0)
-TRACE:=echo "---> "
-else
-TRACE:=:
+ifndef KBUILD_VERBOSE
+  KBUILD_VERBOSE = 0
 endif
 
-ifeq (${shell [ "$(V)" -ge 5 ] && echo 1},)
-PKG_TRACE:=:
+ifneq ($(KBUILD_VERBOSE),0)
+  quiet =
+  Q =
 else
-PKG_TRACE:=echo "------> "
+  quiet=quiet_
+  Q = @
 endif
 
-ifeq (${shell [ "$(V)" -ge 10 ] && echo 1},)
-EXTRA_MAKEFLAGS:=-s
-MAKE_TRACE:=2>&1 >&/dev/null || { echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; }
-else
-MAKE_TRACE:=
-EXTRA_MAKEFLAGS:=
-TRACE:=:
-PKG_TRACE:=:
-endif
 
+CP=cp -fpR
 MAKE1=make
-MAKEFLAGS=-j$(BR2_JLEVEL) V=$(V) $(EXTRA_MAKEFLAGS)
+MAKEFLAGS=-j$(CONFIG_JLEVEL) V=$(V) $(EXTRA_MAKEFLAGS)
 # Strip off the annoying quoting
-ARCH:=$(strip $(subst ",, $(BR2_ARCH)))
-WGET:=$(strip $(subst ",, $(BR2_WGET)))
-GCC_VERSION:=$(strip $(subst ",, $(BR2_GCC_VERSION)))
-GCC_USE_SJLJ_EXCEPTIONS:=$(strip $(subst ",, $(BR2_GCC_USE_SJLJ_EXCEPTIONS)))
-TARGET_OPTIMIZATION:=$(strip $(subst ",, $(BR2_TARGET_OPTIMIZATION)))
+ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
+WGET:=$(strip $(subst ",, $(CONFIG_WGET)))
+GCC_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))
+GCC_USE_SJLJ_EXCEPTIONS:=$(strip $(subst ",, $(CONFIG_GCC_USE_SJLJ_EXCEPTIONS)))
+TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
 #"))"))"))"))")) # for vim's broken syntax highlighting :)
 
 
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
 # gcc 3.4.x soft float configuration is different than previous versions.
 ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
 SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
@@ -56,13 +51,13 @@ ARCH_FPU_SUFFIX:=
 endif
 
 
-ifeq ($(BR2_TAR_VERBOSITY),y)
+ifeq ($(CONFIG_TAR_VERBOSITY),y)
 TAR_OPTIONS=-xvf
 else
 TAR_OPTIONS=-xf
 endif
 
-ifneq ($(BR2_LARGEFILE),y)
+ifneq ($(CONFIG_LARGEFILE),y)
 DISABLE_LARGEFILE= --disable-largefile
 endif
 TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
@@ -123,7 +118,7 @@ else
 DISABLE_NLS:=--disable-nls
 endif
 
-ifeq ($(BR2_ENABLE_MULTILIB),y)
+ifeq ($(CONFIG_ENABLE_MULTILIB),y)
 MULTILIB:=--enable-multilib
 endif
 
@@ -131,9 +126,13 @@ endif
 IPKG_BUILD := PATH="$(TARGET_PATH)" ipkg-build -c -o root -g root
 # where to build (and put) .ipk packages
 IPKG_TARGET_DIR := $(PACKAGE_DIR)
-IPKG:=IPKG_TMP=$(BUILD_DIR)/tmp IPKG_INSTROOT=$(TARGET_DIR) IPKG_CONF_DIR=$(STAGING_DIR)/etc $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
+IPKG:=IPKG_TMP=$(BUILD_DIR)/tmp IPKG_INSTROOT=$(TARGET_DIR) IPKG_CONF_DIR=$(STAGING_DIR)/etc IPKG_OFFLINE_ROOT=$(BUILD_DIR)/root $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
 IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
 
 RSTRIP:=STRIP="$(STRIP)" $(SCRIPT_DIR)/rstrip.sh
 RSTRIP_KMOD:=STRIP="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" $(SCRIPT_DIR)/rstrip.sh
 
+
+all:
+.PHONY: FORCE
+FORCE: