add dependencies from the NEEDS variable to ipkg/control
[openwrt.git] / rules.mk
index c23d418..0e7dd2e 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -1,43 +1,27 @@
+ifeq ($(DUMP),)
 include $(TOPDIR)/.config
+endif
 
 SHELL=/bin/bash
 export SHELL
 
-ifeq ($(V),)
-V=5
+ifdef V
+  ifeq ("$(origin V)", "command line")
+    KBUILD_VERBOSE = $(V)
+  endif
 endif
-
-
-ifneq ($(V),0)
-TRACE:=echo "---> "
-START_TRACE:=echo -n "---> "
-END_TRACE:=echo
-else
-START_TRACE:=:
-END_TRACE:=:
-TRACE:=:
+ifndef KBUILD_VERBOSE
+  KBUILD_VERBOSE = 0
 endif
 
-ifeq (${shell [ "$(V)" -ge 5 ] && echo 1},)
-CMD_TRACE:=:
-PKG_TRACE:=:
+ifneq ($(KBUILD_VERBOSE),0)
+  quiet =
+  Q =
 else
-CMD_TRACE:=echo -n
-PKG_TRACE:=echo "------> "
+  quiet=quiet_
+  Q = @
 endif
 
-ifeq (${shell [ "$(V)" -ge 10 ] && echo 1},)
-EXTRA_MAKEFLAGS:=-s
-MAKE_TRACE:=2>&1 >&/dev/null || { echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; }
-else
-MAKE_TRACE:=
-EXTRA_MAKEFLAGS:=
-TRACE:=:
-PKG_TRACE:=:
-CMD_TRACE:=:
-START_TRACE:=:
-END_TRACE:=:
-endif
 
 CP=cp -fpR
 MAKE1=make
@@ -148,3 +132,7 @@ IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
 RSTRIP:=STRIP="$(STRIP)" $(SCRIPT_DIR)/rstrip.sh
 RSTRIP_KMOD:=STRIP="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" $(SCRIPT_DIR)/rstrip.sh
 
+
+all:
+.PHONY: FORCE
+FORCE: