util-linux: fix endianess bug and stage libraries properly
[openwrt.git] / package / util-linux / Makefile
index e72342a..ed2c10f 100644 (file)
@@ -8,15 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
-PKG_VERSION:=2.20.1
-PKG_RELEASE:=1
+PKG_VERSION:=2.21.2
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.20
-PKG_MD5SUM:=fcd18041c5390178b1aadc2fd298bee8
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.21
+PKG_MD5SUM:=54ba880f1d66782c2287ee2c898520e9
+
+PKG_LICENSE:=GPLv2 LGPLv2.1 BSD-3c
+PKG_LICENSE_FILES:=COPYING getopt/COPYING libblkid/COPYING libmount/COPYING Documentation/licenses/COPYING.GPLv2 Documentation/licenses/COPYING.LGPLv2.1 libuuid/COPYING Documentation/licenses/COPYING.BSD-3
 
 PKG_BUILD_PARALLEL:=1
-PKG_BUILD_DEPENDS=e2fsprogs libncurses
+PKG_BUILD_DEPENDS:=libncurses
 PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
@@ -27,148 +30,427 @@ define Package/util-linux/Default
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
-CONFIGURE_VARS += \
-       scanf_cv_type_modifier="ms"
-
 CONFIGURE_ARGS += \
-       --disable-nls \
-       --disable-tls
+       --enable-new-mount      \
+       --with-ncurses          \
+       --disable-nls           \
+       --disable-tls           \
+       --without-udev
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               BUILDCC="$(HOSTCC)" \
+               DESTDIR="$(1)" \
+               installdirs install-data
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_BUILD_DIR)/libblkid/blkid.pc $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_BUILD_DIR)/libmount/mount.pc $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_BUILD_DIR)/libuuid/uuid.pc $(1)/usr/lib/pkgconfig
+
+       $(INSTALL_DIR) $(1)/usr/include/blkid
+       $(CP) $(PKG_BUILD_DIR)/libblkid/src/blkid.h $(1)/usr/include/blkid
+       $(INSTALL_DIR) $(1)/usr/include/libmount
+       $(CP) $(PKG_BUILD_DIR)/libmount/src/libmount.h $(1)/usr/include/libmount
+       $(INSTALL_DIR) $(1)/usr/include/uuid
+       $(CP) $(PKG_BUILD_DIR)/libuuid/src/uuid.h $(1)/usr/include/uuid
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.{a,so*} $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.{a,so*} $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.{a,so*} $(1)/usr/lib
+endef
+
+define Package/libblkid
+$(call Package/util-linux/Default)
+  DEPENDS:=+libuuid
+  TITLE:=block device id library
+  SECTION:=libs
+  CATEGORY:=Libraries
+endef
+
+define Package/libblkid/description
+ The libblkid library is used to identify block devices (disks) as to their
+ content (e.g. filesystem type, partitions) as well as extracting additional
+ information such as filesystem labels/volume names, partitions, unique
+ identifiers/serial numbers...
+endef
+
+define Package/libmount
+$(call Package/util-linux/Default)
+  DEPENDS:=+libblkid
+  TITLE:=mount library
+  SECTION:=libs
+  CATEGORY:=Libraries
+endef
+
+define Package/libmount/description
+ The libmount library is used to parse /etc/fstab, /etc/mtab and
+ /proc/self/mountinfo files, manage the mtab file, evaluate mount options...
+endef
+
+define Package/libuuid
+$(call Package/util-linux/Default)
+  TITLE:=DCE compatible Universally Unique Identifier library
+  SECTION:=libs
+  CATEGORY:=Libraries
+endef
+
+define Package/libuuid/description
+ The UUID library is used to generate unique identifiers for objects
+ that may be accessible beyond the local system. This library
+ generates UUIDs compatible with those created by the Open Software
+ Foundation (OSF) Distributed Computing Environment (DCE) utility.
+endef
+
+define Package/agetty
+$(call Package/util-linux/Default)
+  TITLE:=alternative Linux getty
+  SUBMENU=Terminal
+endef
+
+define Package/agetty/description
+ agetty opens a tty port, prompts for a login name and invokes the
+ /bin/login command
+endef
+
+define Package/blkid
+$(call Package/util-linux/Default)
+  TITLE:=locate/print block device attributes
+  DEPENDS:= +libblkid
+  SUBMENU=disc
+endef
+
+define Package/blkid/description
+ The blkid program is the command-line interface to working with the libblkid
+ library.
+endef
+
+define Package/cal
+$(call Package/util-linux/Default)
+  TITLE:=display a calendar
+  DEPENDS:= +libncurses
+endef
+
+define Package/cal/description
+ cal displays a simple calendar
+endef
 
 define Package/cfdisk
 $(call Package/util-linux/Default)
+  TITLE:=display or manipulate disk partition table
+  DEPENDS:= +libblkid +libncurses
   SUBMENU:=disc
-  TITLE:=Partition table manipulation utility
-  DEPENDS:= +libncurses
 endef
 
 define Package/cfdisk/description
- This package contains a utility for managing disk partition tables.
+ cfdisk is a curses-based program for partitioning any hard disk drive
+endef
+
+define Package/dmesg
+$(call Package/util-linux/Default)
+  TITLE:=print or control the kernel ring buffer
+endef
+
+define Package/dmesg/description
+ dmesg  is used to examine or control the kernel ring buffer
 endef
 
 define Package/fdisk
 $(call Package/util-linux/Default)
-  TITLE:=Partition table manipulation utility
+  TITLE:=manipulate disk partition table
+  DEPENDS:= +libblkid
   SUBMENU=disc
 endef
 
 define Package/fdisk/description
- This package contains a utility for managing disk partition tables.
+ a menu-driven program for creation and manipulation of partition tables
 endef
 
-define Package/sfdisk
+define Package/findfs
 $(call Package/util-linux/Default)
-  TITLE:=Partition table manipulation utility (Command-line)
+  TITLE:=find a filesystem by label or UUID
+  DEPENDS:= +libblkid
   SUBMENU=disc
 endef
 
-define Package/sfdisk/description
- This package contains a utility for managing disk partition tables using command-line only.
+define Package/findfs/description
+ findfs will search the disks in the system looking for a filesystem which has
+ a label matching label or a UUID equal to uuid
+endef
+
+define Package/flock
+$(call Package/util-linux/Default)
+  TITLE:=manage locks from shell scripts
+endef
+
+define Package/flock/description
+  manages flock locks from within shell scripts or the command line
 endef
 
 define Package/getopt
 $(call Package/util-linux/Default)
-  TITLE:=Tool for parsing command parameters
+  TITLE:=parse command options (enhanced)
 endef
 
 define Package/getopt/description
- getopt is a program to help shell scripts parse command-line parameters.
+ getopt is used to break up (parse) options in command lines for easy parsing
+ by shell procedures, and to check for legal options
 endef
 
 define Package/hwclock
 $(call Package/util-linux/Default)
-  TITLE:=Utilities for managing the hardware clock
+  TITLE:=query or set the hardware clock
 endef
 
 define Package/hwclock/description
- This package contains a utility for managing the hardware clock.
+ hwclock is a tool for accessing the Hardware Clock
+endef
+
+define Package/logger
+$(call Package/util-linux/Default)
+  TITLE:=a shell command interface to the syslog system log module
+endef
+
+define Package/logger/description
+ logger makes entries in the system log, it provides a shell command interface
+ to the syslog system log module
+endef
+
+define Package/look
+$(call Package/util-linux/Default)
+  TITLE:=display lines beginning with a given string
+endef
+
+define Package/look/description
+ look utility displays any lines in file which contain string
 endef
 
 define Package/losetup
 $(call Package/util-linux/Default)
-  TITLE:=Loopback devices setup and control utility
+  TITLE:=set up and control loop devices
 endef
 
 define Package/losetup/description
- This package contains a utility for managing loopback devices.
+ losetup is used to associate loop devices with regular files or block devices,
+ to detach loop devices and to query the status of a loop device
 endef
 
-define Package/swap-utils
+define Package/lsblk
 $(call Package/util-linux/Default)
-  SUBMENU:=disc
-  TITLE:=Swap space management utilities
-  DEPENDS+= +libblkid +libuuid
+  TITLE:=list block devices
+  DEPENDS:= +libblkid
+  SUBMENU=disc
 endef
 
-define Package/swap-utils/description
- This package contains a collection of tools for managing swap space:
- - mkswap
- - swapon
- - swapoff
+define Package/lsblk/description
+ lsblk lists information about all or the specified block devices
+endef
+
+define Package/mcookie
+$(call Package/util-linux/Default)
+  TITLE:=generate magic cookies for xauth
+endef
+
+define Package/mcookie/description
+ mcookie generates a 128-bit random hexadecimal number for use with the X
+ authority system
 endef
 
 define Package/mount-utils
 $(call Package/util-linux/Default)
-  TITLE:=Devices mount/unmounting utilities
-  DEPENDS+= +libblkid +libuuid
+  TITLE:=related (u)mount utilities
+  DEPENDS+= +libmount
 endef
 
 define Package/mount-utils/description
- This package contains utilities to mount/unmount devices.
+ contains: mount, umount, findmnt
 endef
 
-define Package/flock
+define Package/namei
 $(call Package/util-linux/Default)
-  TITLE:=Manage file locks from shell scripts
+  TITLE:=follow a pathname until a terminal point is found
 endef
 
-define Package/flock/description
-  This package contains a utility for managing file locks from shell scripts.
+define Package/namei/description
+ namei uses its arguments as pathnames to any type of Unix file (symlinks,
+ files, directories, and so forth)
+endef
+
+define Package/rename
+$(call Package/util-linux/Default)
+  TITLE:=rename files
+endef
+
+define Package/rename/description
+ rename will rename the specified files by replacing the first occurrence of
+ expression in their name by replacement
+endef
+
+define Package/partx-utils
+$(call Package/util-linux/Default)
+  TITLE:=inform kernel about the presence and numbering of on-disk partitions
+  DEPENDS:= +libblkid
+  SUBMENU=disc
+endef
+
+define Package/partx-utils/description
+ contains partx, addpart, delpart
+endef
+
+define Package/script-utils
+$(call Package/util-linux/Default)
+  TITLE:=make and replay typescript of terminal session
+  SUBMENU=Terminal
+endef
+
+define Package/script-utils/description
+ contains: script, scriptreplay
 endef
 
 define Package/setterm
 $(call Package/util-linux/Default)
-  TITLE:=Tool for setting terminal attributes
-  SUBMENU:=Terminal
+  TITLE:=set terminal attributes
   DEPENDS:= +libncurses
+  SUBMENU:=Terminal
 endef
 
 define Package/setterm/description
-  This package contains a utility for setting terminal attributes.
+ setterm writes to standard output a character string that will invoke the
+ specified terminal capabilities
+endef
+
+define Package/sfdisk
+$(call Package/util-linux/Default)
+  TITLE:=partition table manipulator for Linux
+  SUBMENU=disc
+endef
+
+define Package/sfdisk/description
+ list the size of a partition, list the partitions on a device, check the
+ partitions on a device and repartition a device
+endef
+
+define Package/swap-utils
+$(call Package/util-linux/Default)
+  TITLE:=swap space management utilities
+  DEPENDS+= +libblkid
+  SUBMENU:=disc
+endef
+
+define Package/swap-utils/description
+ contains: mkswap, swaplabel, swapon, swapoff
+endef
+
+define Package/uuidd
+$(call Package/util-linux/Default)
+  TITLE:=UUID generation daemon
+  DEPENDS:= +libuuid
+endef
+
+define Package/uuidd/description
+ The uuidd daemon is used by the UUID library to generate universally unique
+ identifiers (UUIDs), especially time-based UUIDs, in a secure and
+ guaranteed-unique fashion, even in the face of large numbers of threads
+ running on different CPUs trying to grab UUIDs.
+endef
+
+define Package/uuidgen
+$(call Package/util-linux/Default)
+  TITLE:=create a new UUID value
+  DEPENDS:= +libuuid
+endef
+
+define Package/uuidgen/description
+ The uuidgen program creates (and prints) a new universally unique identifier
+ (UUID) using the libuuid library. The new UUID can reasonably be considered
+ unique among all UUIDs created on the local system, and among UUIDs created on
+ other systems in the past and in the future.
 endef
 
-define Package/script
+define Package/wall
 $(call Package/util-linux/Default)
-  TITLE:=Make typescript of terminal session
+  TITLE:=send a message to everybody's terminal
   SUBMENU=Terminal
 endef
 
-define Package/script/description
- Script makes a typescript of everything printed on your terminal.
+define Package/wall/description
+ wall sends a message to everybody logged in with their mesg permission
+ set to yes
+endef
+
+define Package/whereis
+$(call Package/util-linux/Default)
+  TITLE:=locate the binary, source, and manual page files for a command
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/disk-utils mkswap
-       $(MAKE) -C $(PKG_BUILD_DIR)/fdisk cfdisk fdisk sfdisk
-       $(MAKE) -C $(PKG_BUILD_DIR)/getopt getopt
-       $(MAKE) -C $(PKG_BUILD_DIR)/hwclock hwclock
-       $(MAKE) -C $(PKG_BUILD_DIR)/mount losetup mount swapon umount
-       $(MAKE) -C $(PKG_BUILD_DIR)/sys-utils flock
-       $(MAKE) -C $(PKG_BUILD_DIR)/term-utils setterm script
+define Package/whereis/description
+ whereis locates source/binary and manuals sections for specified files
+endef
+
+define Package/wipefs
+$(call Package/util-linux/Default)
+  TITLE:=wipe a signature from a device
+  DEPENDS:= +libblkid
+  SUBMENU:=disc
+endef
+
+define Package/wipefs/description
+ wipefs can erase filesystem, raid or partition table signatures (magic
+ strings) from the specified device to make the signature invisible for
+ libblkid.
+endef
+
+define Package/libblkid/install
+        $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.so.* $(1)/usr/lib/
+endef
+
+define Package/libmount/install
+        $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.so.* $(1)/usr/lib/
+endef
+
+define Package/libuuid/install
+        $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.so.* $(1)/usr/lib/
+endef
+
+define Package/agetty/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/agetty $(1)/usr/sbin/
+endef
+
+define Package/blkid/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/.libs/blkid $(1)/usr/sbin/
+endef
+
+define Package/cal/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/cal $(1)/usr/bin/
 endef
 
 define Package/cfdisk/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/.libs/cfdisk $(1)/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/.libs/cfdisk $(1)/usr/sbin/
 endef
 
 define Package/fdisk/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/.libs/fdisk $(1)/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/.libs/fdisk $(1)/usr/sbin/
 endef
 
-define Package/sfdisk/install
+define Package/findfs/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/sfdisk $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/.libs/findfs $(1)/usr/sbin/
+endef
+
+define Package/flock/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/flock $(1)/usr/bin/
 endef
 
 define Package/getopt/install
@@ -177,30 +459,63 @@ define Package/getopt/install
 endef
 
 define Package/hwclock/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/usr/sbin/
+endef
+
+define Package/logger/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/logger $(1)/usr/bin/
+endef
+
+define Package/look/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/look $(1)/usr/bin/
 endef
 
 define Package/losetup/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/losetup $(1)/usr/sbin/
 endef
 
-define Package/swap-utils/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/.libs/mkswap $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/.libs/swapon $(1)/sbin/
-       ln -sf swapon $(1)/sbin/swapoff
+define Package/lsblk/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/.libs/lsblk $(1)/usr/bin/
+endef
+
+define Package/mcookie/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/mcookie $(1)/usr/bin/
 endef
 
 define Package/mount-utils/install
-       $(INSTALL_DIR) $(1)/bin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/.libs/{u,}mount $(1)/bin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/.libs/{u,}mount $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/.libs/mountpoint $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/.libs/findmnt $(1)/usr/bin/
 endef
 
-define Package/flock/install
+define Package/namei/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/flock $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/namei $(1)/usr/bin/
+endef
+
+define Package/rename/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/rename $(1)/usr/bin/
+endef
+
+define Package/partx-utils/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/partx/.libs/partx $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/partx/addpart $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/partx/delpart $(1)/usr/sbin/
+endef
+
+define Package/script-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/script $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/scriptreplay $(1)/usr/bin/
 endef
 
 define Package/setterm/install
@@ -208,19 +523,72 @@ define Package/setterm/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/setterm $(1)/usr/bin/
 endef
 
-define Package/script/install
+define Package/sfdisk/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/sfdisk $(1)/usr/sbin/
+endef
+
+define Package/swap-utils/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/.libs/mkswap $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/.libs/swaplabel $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/.libs/swapon $(1)/usr/sbin/
+       ln -sf swapon $(1)/usr/sbin/swapoff
+endef
+
+define Package/uuidd/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/.libs/uuidd $(1)/usr/sbin/
+endef
+
+define Package/uuidgen/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/script $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/.libs/uuidgen $(1)/usr/bin/
+endef
+
+define Package/wall/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/wall $(1)/usr/bin/
 endef
 
+define Package/whereis/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/whereis $(1)/usr/bin/
+endef
+
+define Package/wipefs/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/.libs/wipefs $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,libblkid))
+$(eval $(call BuildPackage,libmount))
+$(eval $(call BuildPackage,libuuid))
+$(eval $(call BuildPackage,agetty))
+$(eval $(call BuildPackage,blkid))
+$(eval $(call BuildPackage,cal))
 $(eval $(call BuildPackage,cfdisk))
+$(eval $(call BuildPackage,dmesg))
 $(eval $(call BuildPackage,fdisk))
-$(eval $(call BuildPackage,sfdisk))
+$(eval $(call BuildPackage,findfs))
+$(eval $(call BuildPackage,flock))
 $(eval $(call BuildPackage,getopt))
 $(eval $(call BuildPackage,hwclock))
+$(eval $(call BuildPackage,logger))
+$(eval $(call BuildPackage,look))
 $(eval $(call BuildPackage,losetup))
-$(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,lsblk))
+$(eval $(call BuildPackage,mcookie))
 $(eval $(call BuildPackage,mount-utils))
-$(eval $(call BuildPackage,flock))
+$(eval $(call BuildPackage,namei))
+$(eval $(call BuildPackage,rename))
+$(eval $(call BuildPackage,partx-utils))
+$(eval $(call BuildPackage,script-utils))
 $(eval $(call BuildPackage,setterm))
-$(eval $(call BuildPackage,script))
+$(eval $(call BuildPackage,sfdisk))
+$(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,uuidd))
+$(eval $(call BuildPackage,uuidgen))
+$(eval $(call BuildPackage,wall))
+$(eval $(call BuildPackage,whereis))
+$(eval $(call BuildPackage,wipefs))