strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt.git] / package / util-linux / Makefile
index 673ade4..40f443e 100644 (file)
@@ -1,54 +1,86 @@
-# $Id: Makefile 3822 2006-05-24 07:01:52Z nico $
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
-PKG_RELEASE:=1
-PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/
+PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/util-linux/Default
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@!TARGET_ETRAX
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
 
 define Package/fdisk
-SECTION:=base
-CATEGORY:=Utilities
-TITLE:=Partition table manipulation utility
-DESCRIPTION:=A partition table manipulation utility
-URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+  $(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  DESCRIPTION:=\
+       This package contains a utility for managing disk partition tables.
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
+
+define Package/cfdisk
+  $(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  DEPENDS+= +libncurses
+  DESCRIPTION:=\
+       This package contains a utility for managing disk partition tables.
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
 define Package/losetup
-$(call Package/fdisk)
-TITLE:=Loopback devices setup and control utility
-DESCRIPTION:=A loopback devices setup and control utility
+  $(call Package/util-linux/Default)
+  TITLE:=Loopback devices setup and control utility
+  DESCRIPTION:=\
+       This package contains a utility for managing loopback devices.
 endef
 
 define Package/swap-utils
-$(call Package/fdisk)
-TITLE:=Swap space management utilities
-DESCRIPTION:=A collection of tools to manage swap space \\\
-    * mkswap\\\
-    * swapon\\\
-    * swapoff
+  $(call Package/util-linux/Default)
+  TITLE:=Swap space management utilities
+  DESCRIPTION:=\
+       This package contains a collection of tools for managing swap space: \\\
+       - mkswap\\\
+       - swapon\\\
+       - swapoff
+endef
+
+define Package/hwclock
+  $(call Package/util-linux/Default)
+  TITLE:=Utilities for managing the hardware clock
+  DESCRIPTION:=\
+        This package contains a utility for managing the hardware clock
+endef
+
+define Build/Configure
+       # this is NOT GNU configure!
+       ( cd $(PKG_BUILD_DIR); \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               ./configure \
+       );
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                OPT="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALLSUID="install -m 4755" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
@@ -57,21 +89,34 @@ define Package/Template
                rm -f $(PKG_BUILD_DIR)/.built; \
                $(MAKE) $(PKG_BUILD_DIR)/.built; \
        fi
-       install -d -m0755 $(2)
+       $(INSTALL_DIR) $(2)
        $(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
 endef
 
 define Package/fdisk/install
        $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
 endef
+
+define Package/cfdisk/install
+       $(call Package/Template,sbin/cfdisk,$(1)/usr/sbin)
+endef
+
 define Package/losetup/install
        $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
 endef
+
 define Package/swap-utils/install
        $(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
        $(call Package/Template,sbin/swapon,$(1)/usr/sbin)
        $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
 endef
+
+define Package/hwclock/install
+       $(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
+endef
+
 $(eval $(call BuildPackage,fdisk))
+$(eval $(call BuildPackage,cfdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,hwclock))