package/util-linux: don't lie about availability of '%ms' scanf modifier
[openwrt.git] / package / util-linux / Makefile
index 40d1579..3a64463 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
-PKG_VERSION:=2.21.1
+PKG_VERSION:=2.21.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.21
-PKG_MD5SUM:=ad602dcd528f340b1329cfa6200d8f80
+PKG_MD5SUM:=54ba880f1d66782c2287ee2c898520e9
 
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=libncurses
@@ -27,14 +27,14 @@ define Package/util-linux/Default
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
-CONFIGURE_VARS += \
-       scanf_cv_alloc_modifier="ms"
-
 CONFIGURE_ARGS += \
        --enable-new-mount      \
        --with-ncurses          \
        --disable-nls           \
-       --disable-tls
+       --disable-tls           \
+       --without-udev
+
+TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -62,6 +62,7 @@ endef
 
 define Package/libblkid
 $(call Package/util-linux/Default)
+  DEPENDS:=+libuuid
   TITLE:=block device id library
   SECTION:=libs
   CATEGORY:=Libraries
@@ -76,12 +77,13 @@ endef
 
 define Package/libmount
 $(call Package/util-linux/Default)
+  DEPENDS:=+libblkid
   TITLE:=mount library
   SECTION:=libs
   CATEGORY:=Libraries
 endef
 
-define Package/libblkid/description
+define Package/libmount/description
  The libmount library is used to parse /etc/fstab, /etc/mtab and
  /proc/self/mountinfo files, manage the mtab file, evaluate mount options...
 endef
@@ -114,7 +116,7 @@ endef
 define Package/blkid
 $(call Package/util-linux/Default)
   TITLE:=locate/print block device attributes
-  DEPENDS:= +libblkid +libuuid
+  DEPENDS:= +libblkid
   SUBMENU=disc
 endef
 
@@ -136,7 +138,7 @@ endef
 define Package/cfdisk
 $(call Package/util-linux/Default)
   TITLE:=display or manipulate disk partition table
-  DEPENDS:= +libblkid +libncurses +libuuid
+  DEPENDS:= +libblkid +libncurses
   SUBMENU:=disc
 endef
 
@@ -156,7 +158,7 @@ endef
 define Package/fdisk
 $(call Package/util-linux/Default)
   TITLE:=manipulate disk partition table
-  DEPENDS:= +libblkid +libuuid
+  DEPENDS:= +libblkid
   SUBMENU=disc
 endef
 
@@ -167,7 +169,7 @@ endef
 define Package/findfs
 $(call Package/util-linux/Default)
   TITLE:=find a filesystem by label or UUID
-  DEPENDS:= +libblkid +libuuid
+  DEPENDS:= +libblkid
   SUBMENU=disc
 endef
 
@@ -210,7 +212,8 @@ $(call Package/util-linux/Default)
 endef
 
 define Package/logger/description
- logger makes entries in the system log, it provides a shell command interface to the syslog system log module
+ logger makes entries in the system log, it provides a shell command interface
+ to the syslog system log module
 endef
 
 define Package/look
@@ -235,7 +238,7 @@ endef
 define Package/lsblk
 $(call Package/util-linux/Default)
   TITLE:=list block devices
-  DEPENDS:= +libblkid +libuuid
+  DEPENDS:= +libblkid
   SUBMENU=disc
 endef
 
@@ -256,7 +259,7 @@ endef
 define Package/mount-utils
 $(call Package/util-linux/Default)
   TITLE:=related (u)mount utilities
-  DEPENDS+= +libblkid +libmount +libuuid
+  DEPENDS+= +libmount
 endef
 
 define Package/mount-utils/description
@@ -286,7 +289,7 @@ endef
 define Package/partx-utils
 $(call Package/util-linux/Default)
   TITLE:=inform kernel about the presence and numbering of on-disk partitions
-  DEPENDS:= +libblkid +libuuid
+  DEPENDS:= +libblkid
   SUBMENU=disc
 endef
 
@@ -307,6 +310,7 @@ endef
 define Package/setterm
 $(call Package/util-linux/Default)
   TITLE:=set terminal attributes
+  DEPENDS:= +libncurses
   SUBMENU:=Terminal
 endef
 
@@ -329,7 +333,7 @@ endef
 define Package/swap-utils
 $(call Package/util-linux/Default)
   TITLE:=swap space management utilities
-  DEPENDS+= +libblkid +libuuid
+  DEPENDS+= +libblkid
   SUBMENU:=disc
 endef
 
@@ -370,7 +374,7 @@ $(call Package/util-linux/Default)
 endef
 
 define Package/wall/description
Wall sends a message to everybody logged in with their mesg permission
wall sends a message to everybody logged in with their mesg permission
  set to yes
 endef
 
@@ -379,14 +383,14 @@ $(call Package/util-linux/Default)
   TITLE:=locate the binary, source, and manual page files for a command
 endef
 
-define Package/wipefs/description
+define Package/whereis/description
  whereis locates source/binary and manuals sections for specified files
 endef
 
 define Package/wipefs
 $(call Package/util-linux/Default)
   TITLE:=wipe a signature from a device
-  DEPENDS:= +libblkid +libuuid
+  DEPENDS:= +libblkid
   SUBMENU:=disc
 endef