Add a few SPDX tags
[openwrt.git] / package / system / procd / Makefile
index d38c0f0..3557eb8 100644 (file)
@@ -8,18 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2014-10-06
+PKG_VERSION:=2014-11-01
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=f45672d80bf2fec4ccb7363de1da6adb9e3f4421
+PKG_SOURCE_VERSION:=174777181850705df7c6dbe234bd7e93d352666a
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
-PKG_LICENSE:=GPLv2
+PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=
 
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
@@ -43,6 +43,23 @@ define Package/procd-nand
   TITLE:=OpenWrt sysupgrade nand helper
 endef
 
+define Package/procd/config
+menu "Configuration"
+       depends on PACKAGE_procd
+
+config PROCD_SHOW_BOOT
+       bool
+       default n
+       prompt "Print the shutdown to the console as well as logging it to syslog"
+endmenu
+endef
+
+PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT
+
+ifeq ($(CONFIG_PACKAGE_PROCD_SHOW_BOOT),y)
+  CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE
+endif
+
 define Package/procd/install
        $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions