Use $(CP) instead of $(INSTALL_BIN) for binaries.
[openwrt.git] / package / shfs / Makefile
index b1509a7..8467bc1 100644 (file)
@@ -1,29 +1,74 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=shfs
 PKG_VERSION:=0.35
 PKG_RELEASE:=2
-PKG_MD5SUM:=016f49d71bc32eee2b5d11fc1600cfbe
 
-PKG_SOURCE_URL:=@SF/shfs
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/shfs
+PKG_MD5SUM:=016f49d71bc32eee2b5d11fc1600cfbe
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/shfs/Default
+  TITLE:=ShFS
+  URL:=http://shfs.sourceforge.net/
+endef
+
+define Package/shfs/Default/description
+ ShFS is a simple and easy to use Linux kernel module which allows you to 
+ mount remote filesystems using a plain shell (SSH) connection. When using 
+ ShFS, you can access all remote files just like the local ones, only the 
+ access is governed through the transport security of SSH.
+endef
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+define KernelPackage/shfs
+$(call Package/shfs/Default)
+  TITLE+= (kernel module)
+  DEPENDS:=@LINUX_2_4
+  FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
+  SUBMENU:=Filesystems
+  AUTOLOAD:=$(call AutoLoad,40,shfs)
+endef
 
-include $(TOPDIR)/package/rules.mk
+define KernelPackage/shfs/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS kernel module.
+endef
 
-$(eval $(call PKG_template,SHFS_UTILS,shfs-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+define Package/shfs-utils
+$(call Package/shfs/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS+=+kmod-shfs
+  TITLE+= (utilities)
+endef
 
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
+define Package/shfs-utils/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS utilities.
+endef
 
-$(PKG_BUILD_DIR)/.built: 
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               OFLAGS="$(TARGET_CFLAGS)" \
+               CC="$(TARGET_CC)" \
+               LINKER="$(TARGET_CC)" \
+               KERNEL="$(LINUX_VERSION)" \
+               KERNEL_SOURCES="$(LINUX_DIR)" \
+               ROOT="$(PKG_INSTALL_DIR)" \
+               module module-install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                OFLAGS="$(TARGET_CFLAGS)" \
                CC="$(TARGET_CC)" \
@@ -31,12 +76,14 @@ $(PKG_BUILD_DIR)/.built:
                KERNEL_SOURCES="$(LINUX_DIR)" \
                ROOT="$(PKG_INSTALL_DIR)" \
                utils utils-install
-       touch $@
+endef
 
-$(IPKG_SHFS_UTILS):
-       install -m0755 -d $(IDIR_SHFS_UTILS)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/shfs{,u}mount $(IDIR_SHFS_UTILS)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mount.shfs $(IDIR_SHFS_UTILS)/usr/sbin/
-       $(RSTRIP) $(IDIR_SHFS_UTILS)
-       $(IPKG_BUILD) $(IDIR_SHFS_UTILS) $(PACKAGE_DIR)
+define Package/shfs-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/mount.shfs $(1)/sbin/
+endef
 
+$(eval $(call KernelPackage,shfs))
+$(eval $(call BuildPackage,shfs-utils))