remove global hostapd builddep on openssl
[openwrt.git] / package / rules.mk
index 540b14f..77a6595 100644 (file)
 ifneq ($(DUMP),)
-all: dumpinfo
+  all: dumpinfo
 else
-all: compile
+  all: compile
 endif
 
 define Build/DefaultTargets
-$(PKG_BUILD_DIR)/.prepared:
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
+  ifeq ($(DUMP),)
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.prepared: package-clean
+      endif
+    endif
+
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.built: package-rebuild
+      endif
+    endif
+  endif
+
+  $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
+       @-rm -rf $(PKG_BUILD_DIR)
+       @mkdir -p $(PKG_BUILD_DIR)
        $(call Build/Prepare)
        touch $$@
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+  $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        $(call Build/Configure)
        touch $$@
 
-ifeq ($(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),.)
-$(PKG_BUILD_DIR)/.prepared: clean
-endif
-
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+  $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
        touch $$@
 
-package-clean:
-       $(call Build/Clean)
-       rm -f $(PKG_BUILD_DIR)/.built
+  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
+       $(call Build/InstallDev)
+       touch $$@
+       
+  ifdef Build/InstallDev
+    compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+  endif
 
-package-recompile:
-       rm -f $(PKG_BUILD_DIR)/.built
+  package-clean: FORCE
+       $(call Build/Clean)
+       $(call Build/UninstallDev)
+       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
-.PHONY: package-clean package-recompile
+  package-rebuild: FORCE
+       @-rm $(PKG_BUILD_DIR)/.built
 
-define Build/DefaultTargets
-endef
+  define Build/DefaultTargets
+  endef
 endef
 
 define Package/Default
-CONFIGFILE:=
-SECTION:=opt
-CATEGORY:=Extra packages
-DEPENDS:=
-MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
-SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
-VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
-PKGARCH:=$(ARCH)
-PRIORITY:=optional
-DEFAULT:=
-MENU:=
-TITLE:=
-DESCRIPTION:=
+  CONFIGFILE:=
+  SECTION:=opt
+  CATEGORY:=Extra packages
+  DEPENDS:=
+  MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
+  SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
+  ifneq ($(PKG_VERSION),)
+    ifneq ($(PKG_RELEASE),)
+      VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+    else
+      VERSION:=$(PKG_VERSION)
+    endif
+  else
+    VERSION:=$(PKG_RELEASE)
+  endif
+  PKGARCH:=$(ARCH)
+  PRIORITY:=optional
+  DEFAULT:=
+  MENU:=
+  TITLE:=
+  DESCRIPTION:=
 endef
 
 define BuildPackage
-$(eval $(call Package/Default))
-$(eval $(call Package/$(1)))
+  $(eval $(call Package/Default))
+  $(eval $(call Package/$(1)))
 
-ifeq ($(TITLE),)
-$$(error Package $(1) has no TITLE)
-endif
-ifeq ($(CATEGORY),)
-$$(error Package $(1) has no CATEGORY)
-endif
-ifeq ($(PRIORITY),)
-$$(error Package $(1) has no PRIORITY)
-endif
-ifeq ($(VERSION),)
-$$(error Package $(1) has no VERSION)
-endif
-ifeq ($(PKGARCH),)
-PKGARCH:=$(ARCH)
-endif
-$(eval 
-ifeq ($(DESCRIPTION),)
-DESCRIPTION:=$(TITLE)
-endif
-)
+  $(foreach FIELD, TITLE CATEGORY PRIORITY VERSION,
+    ifeq ($($(FIELD)),)
+      $$(error Package/$(1) is missing the $(FIELD) field)
+    endif
+  )
 
-IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
-IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
-INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
+  ifeq ($(PKGARCH),)
+    PKGARCH:=$(ARCH)
+  endif
 
-ifneq ($(CONFIG_PACKAGE_$(1)),)
-COMPILE_$(1):=1
-endif
-ifneq ($(DEVELOPER),)
-COMPILE_$(1):=1
-endif
-ifeq ($(CONFIG_PACKAGE_$(1)),y)
-install-targets: $$(INFO_$(1))
-endif
+  ifeq ($(DESCRIPTION),)
+    $(eval DESCRIPTION:=$(TITLE))
+  endif
 
-ifneq ($$(COMPILE_$(1)),)
-ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$(PKG_BUILD_DIR))
-$(PKG_BUILD_DIR)/.built: package-recompile
-endif
+  IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
+  IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
+  INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-compile-targets: $$(IPKG_$(1))
-endif
+  ifeq ($(CONFIG_PACKAGE_$(1)),y)
+    install-targets: $$(INFO_$(1))
+  endif
 
+  ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
+    compile-targets: $$(IPKG_$(1))
+  endif
 
-IDEPEND_$(1):=$$(strip $$(DEPENDS))
+  IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
-DUMPINFO += \
+  DUMPINFO += \
        echo "Package: $(1)"; 
-ifneq ($(MENU),)
-DUMPINFO += \
+
+  ifneq ($(MENU),)
+    DUMPINFO += \
        echo "Menu: $(MENU)";
-endif
-ifneq ($(DEFAULT),)
-DUMPINFO += \
+  endif
+
+  ifneq ($(DEFAULT),)
+    DUMPINFO += \
        echo "Default: $(DEFAULT)";
-endif
-DUMPINFO += \
+  endif
+
+  DUMPINFO += \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
+       echo "Build-Depends: $(PKG_BUILDDEP)"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
-ifneq ($(URL),)
-DUMPINFO += \
+
+  ifneq ($(URL),)
+    DUMPINFO += \
        echo; \
        echo "$(URL)";
-endif
-DUMPINFO += \
+  endif
+
+  DUMPINFO += \
        echo "@@";
 
+  ifneq ($(CONFIG),)
+    DUMPINFO += \
+       echo "Config: $(CONFIG)" | sed -e 's,\\,\n,g'; \
+       echo "@@";
+  endif
 
-$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
+       ( \
+               DEPENDS=; \
+               for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
+                       DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
+               done; \
+               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+       )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
@@ -143,58 +167,62 @@ $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
                [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done
 
-$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
+  $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
+       -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
+       -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
-$$(INFO_$(1)): $$(IPKG_$(1))
+  $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
 
-$(1)-clean:
+  $(1)-clean:
        rm -f $(PACKAGE_DIR)/$(1)_*
-clean: $(1)-clean
 
-ifneq ($(__DEFAULT_TARGETS),1)
-$(eval $(call Build/DefaultTargets))
-endif
+  clean: $(1)-clean
+
+  $$(eval $$(call Build/DefaultTargets,$(1)))
 
 endef
 
 ifneq ($(strip $(PKG_SOURCE)),)
-$(DL_DIR)/$(PKG_SOURCE):
+  $(DL_DIR)/$(PKG_SOURCE):
        $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL)
-       
-$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
 endif
 
 ifneq ($(strip $(PKG_CAT)),)
-define Build/Prepare/Default
-       if [ "$(PKG_CAT)" = "unzip" ]; then \
+  define Build/Prepare/Default
+       @if [ "$(PKG_CAT)" = "unzip" ]; then \
                unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE) ; \
        else \
                $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) - ; \
        fi                                                
-       if [ -d ./patches ]; then \
+       @if [ -d ./patches ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches ; \
        fi
-endef
+  endef
 endif
 
 define Build/Prepare
-$(call Build/Prepare/Default)
+  $(call Build/Prepare/Default)
 endef
 
 define Build/Configure/Default
-       (cd $(PKG_BUILD_DIR); \
+       @(cd $(PKG_BUILD_DIR); \
        [ -x configure ] && \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
+               --program-prefix="" \
+               --program-suffix="" \
                --prefix=/usr \
                --exec-prefix=/usr \
                --bindir=/usr/bin \
@@ -207,53 +235,49 @@ define Build/Configure/Default
                --infodir=/usr/info \
                $(DISABLE_NLS) \
                $(1); \
+               true; \
        )
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,)
+  $(call Build/Configure/Default,)
 endef
 
 define Build/Compile/Default
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                CC=$(TARGET_CC) \
                CROSS="$(TARGET_CROSS)" \
-               PREFIX="$$(IDIR_$(1))" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
                ARCH="$(ARCH)" \
-               DESTDIR="$$(IDIR_$(1))"
+               $(1);
 endef
 
 define Build/Compile
-$(call Build/Compile/Default)
-endef
-
-define Build/Clean
-       $(MAKE) clean
+  $(call Build/Compile/Default,)
 endef
 
 ifneq ($(DUMP),)
-dumpinfo:
-       $(DUMPINFO)
+  dumpinfo: FORCE
+       @$(DUMPINFO)
 else
                
-$(PACKAGE_DIR):
+  $(PACKAGE_DIR):
        mkdir -p $@
 
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.prepared
-configure: $(PKG_BUILD_DIR)/.configured
+  source: $(DL_DIR)/$(PKG_SOURCE)
+  prepare: $(PKG_BUILD_DIR)/.prepared
+  configure: $(PKG_BUILD_DIR)/.configured
 
-compile-targets:
-compile: compile-targets
+  compile-targets:
+  compile: compile-targets
 
-install-targets:
-install: install-targets
+  install-targets:
+  install: install-targets
 
-clean-targets:
-clean: 
+  clean-targets:
+  clean: FORCE
        @$(MAKE) clean-targets
+       $(call Build/Clean)
        rm -rf $(PKG_BUILD_DIR)
 endif
-
-.PHONY: all source prepare compile install clean dumpinfo compile-targets install-targets clean-targets