Add the 93cx6 patch to generic-2.6, correctly fix dependencies on the rt2x00 drivers...
[openwrt.git] / package / rt61 / Makefile
index b40d496..6e7c600 100644 (file)
@@ -22,9 +22,9 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/rt61
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for ralink MiMo pci chipsets 
-  DEPENDS:=@LINUX_2_6_RDC +wireless-tools
+  DEPENDS:=@PCI_SUPPORT +wireless-tools
   DESCRIPTION:=\
-        This package contains a driver for ralink rt61xx pci chipsets.
+        This package contains a driver for ralink rt2x61 pci chipsets.
   URL:=http://rt2x00.serialmonkey.com/
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:= \
@@ -32,6 +32,11 @@ define KernelPackage/rt61
   AUTOLOAD:=$(call AutoLoad,50,rt61)
 endef
 
+define KernelPackage/rt61/install
+       mkdir $(1)/lib/firmware
+       $(CP) -L $(PKG_BUILD_DIR)/Module/rt2*.bin $(1)/lib/firmware
+endef
+
 LINUX_PATCHLEVEL:=$(shell echo "$(LINUX_VERSION)" | cut -d. -f2)
 
 define Build/Compile