add missing pg_config.h header to staging_dir, required to build php5 extension
[openwrt.git] / package / postgresql / Makefile
index 1f37bb7..d83f1af 100644 (file)
@@ -97,6 +97,7 @@ $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
@@ -109,6 +110,7 @@ uninstall-dev:
        rm -rf \
                $(STAGING_DIR)/usr/include/libpq \
                $(STAGING_DIR)/usr/include/libpq-fe.h \
+               $(STAGING_DIR)/usr/include/pg_config.h \
                $(STAGING_DIR)/usr/include/postgres_ext.h \
                $(STAGING_DIR)/usr/include/postgresql \
                $(STAGING_DIR)/usr/lib/libpq.{a,so*} \