license info - revert r43155
[openwrt.git] / package / network / services / samba36 / Makefile
index d6b2b50..4dff34b 100644 (file)
@@ -8,13 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.5
-PKG_RELEASE:=2
+PKG_VERSION:=3.6.24
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/old-versions
+       http://ftp.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=2f0c14547333c1b48fd4728b031e7040
+PKG_MD5SUM:=d98425c0c2b73e08f048d31ffc727fb0
+
+PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=COPYING
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
@@ -46,7 +49,7 @@ endef
 define Package/samba36-server/config
        config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
                int "Maximum level of compiled-in debug messages"
-               depends PACKAGE_samba36-server || PACKAGE_samba36-client
+               depends on PACKAGE_samba36-server || PACKAGE_samba36-client
                default -1
 
 endef
@@ -62,6 +65,8 @@ TARGET_CFLAGS += -DMAX_DEBUG_LEVEL=$(CONFIG_PACKAGE_SAMBA_MAX_DEBUG_LEVEL) -D__l
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_VARS += \
+       ac_cv_lib_attr_getxattr=no \
+       ac_cv_search_getxattr=no \
        ac_cv_file__proc_sys_kernel_core_pattern=yes \
        libreplace_cv_HAVE_C99_VSNPRINTF=yes \
        libreplace_cv_HAVE_GETADDRINFO=yes \
@@ -100,6 +105,7 @@ CONFIGURE_ARGS += \
        --with-piddir=/var/run \
        --with-privatedir=/etc/samba \
        --with-sendfile-support \
+       --without-acl-support \
        --without-cluster-support \
        --without-ads \
        --without-krb5 \
@@ -111,6 +117,7 @@ CONFIGURE_ARGS += \
        --without-libnetapi \
        --without-libsmbclient \
        --without-libsmbsharemodes \
+       --without-libtevent \
        --without-libaddns \
        --with-shared-modules=pdb_tdbsam,pdb_wbc_sam,idmap_nss,nss_info_template,auth_winbind,auth_wbc,auth_domain