odhcpd/6c: Add config menu for prefix class ext.
[openwrt.git] / package / network / services / odhcpd / Makefile
index e660600..c4f76cb 100644 (file)
@@ -22,6 +22,10 @@ PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
+ifneq ($(CONFIG_PACKAGE_odhcpd_ext_prefix_class),0)
+  CMAKE_OPTIONS += -DEXT_PREFIX_CLASS=$(CONFIG_PACKAGE_odhcpd_ext_prefix_class)
+endif
+
 define Package/odhcpd
   SECTION:=net
   CATEGORY:=Network
 define Package/odhcpd
   SECTION:=net
   CATEGORY:=Network
@@ -29,6 +33,13 @@ define Package/odhcpd
   DEPENDS:=+libubox +libuci +libubus
 endef
 
   DEPENDS:=+libubox +libuci +libubus
 endef
 
+define Package/odhcpd/config
+  config PACKAGE_odhcpd_ext_prefix_class
+    int "Prefix Class Extension ID (0 = disabled)"
+    depends on PACKAGE_odhcpd
+    default 0
+endef
+
 define Package/odhcpd/description
  odhcpd is a daemon for serving and relaying IP management protocols to
  configure clients and downstream routers. It tries to follow the RFC 6204
 define Package/odhcpd/description
  odhcpd is a daemon for serving and relaying IP management protocols to
  configure clients and downstream routers. It tries to follow the RFC 6204