license info - revert r43155
[openwrt.git] / package / network / services / lldpd / Makefile
index 2a9954c..3a2e411 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
-PKG_VERSION:=0.6.1
+PKG_VERSION:=0.7.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=d2f9ae67e0bcce0206a3a501a81d0738
+PKG_MD5SUM:=9031734c69940dd79a0a175123275f83
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=ISC
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
+TARGET_CFLAGS+=--std=c99
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lldpd
@@ -28,7 +31,8 @@ define Package/lldpd
   SUBMENU:=Routing and Redirection
   TITLE:=Link Layer Discovery Protocol daemon
   URL:=https://github.com/vincentbernat/lldpd/wiki
-  DEPENDS:=+libevent2
+  DEPENDS:=+libevent2 +USE_EGLIBC:libbsd
+  USERID:=lldp=121:lldp=129
 endef
 
 define Package/lldpd/description
@@ -44,7 +48,7 @@ define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{ctl,d} $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{cli,ctl,d} $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
        $(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
        $(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd
@@ -57,6 +61,7 @@ endef
 CONFIGURE_ARGS += \
        --with-privsep-user=lldp \
        --with-privsep-group=lldp \
-       --with-privsep-chroot=/var/run/lldp
+       --with-privsep-chroot=/var/run/lldp \
+       --with-readline=no
 
 $(eval $(call BuildPackage,lldpd))