hostapd: backport fix for CVE-2015-1863, refresh patches
[openwrt.git] / package / network / services / hostapd / patches / 370-ap_sta_support.patch
index a3d0572..ea235e6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/wpa_supplicant/wpa_supplicant_i.h
 +++ b/wpa_supplicant/wpa_supplicant_i.h
-@@ -96,6 +96,11 @@ struct wpa_interface {
+@@ -110,6 +110,11 @@ struct wpa_interface {
        const char *ifname;
  
        /**
@@ -12,7 +12,7 @@
         * bridge_ifname - Optional bridge interface name
         *
         * If the driver interface (ifname) is included in a Linux bridge
-@@ -325,6 +330,8 @@ struct wpa_supplicant {
+@@ -442,6 +447,8 @@ struct wpa_supplicant {
  #endif /* CONFIG_CTRL_IFACE_DBUS_NEW */
        char bridge_ifname[16];
  
 +
        char *confname;
        char *confanother;
-       struct wpa_config *conf;
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -13,6 +13,10 @@ PKG_CONFIG ?= pkg-config
- CFLAGS += -I../src
- CFLAGS += -I../src/utils
+@@ -14,6 +14,10 @@ CFLAGS += $(EXTRA_CFLAGS)
+ CFLAGS += -I$(abspath ../src)
+ CFLAGS += -I$(abspath ../src/utils)
  
 +ifdef MULTICALL
 +CFLAGS += -DMULTICALL
@@ -34,9 +34,9 @@
  -include .config
  -include $(if $(MULTICALL),../hostapd/.config)
  
-@@ -76,6 +80,8 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
- OBJS_c += ../src/utils/wpa_debug.o
+@@ -84,6 +88,8 @@ OBJS_c += ../src/utils/wpa_debug.o
  OBJS_c += ../src/utils/common.o
+ OBJS += wmm_ac.o
  
 +OBJS += ../src/common/wpa_ctrl.o
 +
  CONFIG_OS=win32
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -109,6 +109,46 @@ extern int wpa_debug_show_keys;
extern int wpa_debug_timestamp;
- extern struct wpa_driver_ops *wpa_drivers[];
+@@ -107,6 +107,55 @@ const char *wpa_supplicant_full_license5
"\n";
+ #endif /* CONFIG_NO_STDOUT_DEBUG */
  
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
-+      const char *cmd = "DOWN";
++      const char *cmd = "STOP_AP";
 +      char buf[256];
-+      int len = sizeof(buf);
++      size_t len = sizeof(buf);
 +
 +      if (wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL) < 0) {
 +              wpa_printf(MSG_ERROR, "\nFailed to stop hostapd AP interfaces\n");
 +{
 +      char *cmd = NULL;
 +      char buf[256];
-+      int len = sizeof(buf);
++      size_t len = sizeof(buf);
 +      enum hostapd_hw_mode hw_mode;
 +      u8 channel;
++      int sec_chan = 0;
 +      int ret;
 +
 +      if (!bss)
 +              return;
 +
++      if (bss->ht_param & HT_INFO_HT_PARAM_STA_CHNL_WIDTH) {
++              int sec = bss->ht_param & HT_INFO_HT_PARAM_SECONDARY_CHNL_OFF_MASK;
++              if (sec == HT_INFO_HT_PARAM_SECONDARY_CHNL_ABOVE)
++                      sec_chan = 1;
++              else if (sec ==  HT_INFO_HT_PARAM_SECONDARY_CHNL_BELOW)
++                      sec_chan = -1;
++      }
++
 +      hw_mode = ieee80211_freq_to_chan(bss->freq, &channel);
-+      if (asprintf(&cmd, "UPDATE channel=%d sec_chan=0 hw_mode=%d ieee80211n=%d",
-+                   channel, hw_mode, !!bss->ht_capab) < 0)
++      if (asprintf(&cmd, "UPDATE channel=%d sec_chan=%d hw_mode=%d",
++                   channel, sec_chan, hw_mode) < 0)
 +              return -1;
 +
 +      ret = wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL);
  /* Configure default/group WEP keys for static WEP */
  int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
  {
-@@ -685,8 +725,12 @@ void wpa_supplicant_set_state(struct wpa
- #endif /* CONFIG_P2P */
+@@ -743,8 +792,12 @@ void wpa_supplicant_set_state(struct wpa
+               wpas_p2p_completed(wpa_s);
  
                sme_sched_obss_scan(wpa_s, 1);
 +              if (wpa_s->hostapd)
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -2906,6 +2950,20 @@ static int wpa_supplicant_init_iface(str
+@@ -4038,6 +4091,20 @@ static int wpa_supplicant_init_iface(str
                           sizeof(wpa_s->bridge_ifname));
        }
  
 +      if (iface->hostapd_ctrl) {
-+              char *cmd = "DOWN";
++              char *cmd = "STOP_AP";
 +              char buf[256];
 +              int len = sizeof(buf);
 +
        /* RSNA Supplicant Key Management - INITIALIZE */
        eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
        eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
-@@ -3125,6 +3183,11 @@ static void wpa_supplicant_deinit_iface(
+@@ -4280,6 +4347,11 @@ static void wpa_supplicant_deinit_iface(
        if (terminate)
                wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_TERMINATING);
  
  #include "drivers/driver.h"
  #include "wpa_supplicant_i.h"
  #include "config.h"
-@@ -245,6 +246,9 @@ static void calculate_update_time(const 
+@@ -277,6 +278,10 @@ static void calculate_update_time(const
  static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
-                            struct os_time *fetch_time)
+                            struct os_reltime *fetch_time)
  {
 +      struct ieee80211_ht_capabilities *capab;
++      struct ieee80211_ht_operation *oper;
 +      struct ieee802_11_elems elems;
 +
        dst->flags = src->flags;
        os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
        dst->freq = src->freq;
-@@ -255,6 +259,12 @@ static void wpa_bss_copy_res(struct wpa_
-       dst->level = src->level;
-       dst->tsf = src->tsf;
+@@ -289,6 +294,15 @@ static void wpa_bss_copy_res(struct wpa_
+       dst->est_throughput = src->est_throughput;
+       dst->snr = src->snr;
  
 +      memset(&elems, 0, sizeof(elems));
 +      ieee802_11_parse_elems((u8 *) (src + 1), src->ie_len, &elems, 0);
 +      capab = (struct ieee80211_ht_capabilities *) elems.ht_capabilities;
++      oper = (struct ieee80211_ht_operation *) elems.ht_operation;
 +      if (capab)
 +              dst->ht_capab = le_to_host16(capab->ht_capabilities_info);
++      if (oper)
++              dst->ht_param = oper->ht_param;
 +
        calculate_update_time(fetch_time, src->age, &dst->last_update);
  }
  
 --- a/wpa_supplicant/main.c
 +++ b/wpa_supplicant/main.c
-@@ -27,7 +27,7 @@ static void usage(void)
-              "  wpa_supplicant [-BddhKLqqstuvW] [-P<pid file>] "
+@@ -33,7 +33,7 @@ static void usage(void)
+              "vW] [-P<pid file>] "
               "[-g<global ctrl>] \\\n"
               "        [-G<group>] \\\n"
 -             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] "
 +             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-H<hostapd path>] "
               "[-p<driver_param>] \\\n"
-              "        [-b<br_ifname>] [-f<debug file>] [-e<entropy file>] "
-              "\\\n"
-@@ -72,6 +72,7 @@ static void usage(void)
+              "        [-b<br_ifname>] [-e<entropy file>]"
+ #ifdef CONFIG_DEBUG_FILE
+@@ -84,6 +84,7 @@ static void usage(void)
  #endif /* CONFIG_DEBUG_LINUX_TRACING */
        printf("  -t = include timestamp in debug messages\n"
               "  -h = show this help text\n"
               "  -L = show license (BSD)\n"
               "  -o = override driver parameter for new interfaces\n"
               "  -O = override ctrl_interface parameter for new interfaces\n"
-@@ -160,7 +161,7 @@ int main(int argc, char *argv[])
+@@ -175,7 +176,7 @@ int main(int argc, char *argv[])
  
        for (;;) {
                c = getopt(argc, argv,
--                         "b:Bc:C:D:de:f:g:G:hi:I:KLNo:O:p:P:qsTtuvW");
-+                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLNo:O:p:P:qsTtuvW");
+-                         "b:Bc:C:D:de:f:g:G:hi:I:KLm:No:O:p:P:qsTtuvW");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLm:No:O:p:P:qsTtuvW");
                if (c < 0)
                        break;
                switch (c) {
-@@ -207,6 +208,9 @@ int main(int argc, char *argv[])
+@@ -222,6 +223,9 @@ int main(int argc, char *argv[])
                        usage();
                        exitcode = 0;
                        goto out;
                        break;
 --- a/wpa_supplicant/bss.h
 +++ b/wpa_supplicant/bss.h
-@@ -69,6 +69,8 @@ struct wpa_bss {
+@@ -72,6 +72,10 @@ struct wpa_bss {
        u8 ssid[32];
        /** Length of SSID */
        size_t ssid_len;
 +      /** HT caapbilities */
 +      u16 ht_capab;
++      /* Five octets of HT Operation Information */
++      u8 ht_param;
        /** Frequency of the channel in MHz (e.g., 2412 = channel 1) */
        int freq;
        /** Beacon interval in TUs (host byte order) */