hostapd: correctly handle macfile uci option
[openwrt.git] / package / network / services / hostapd / Makefile
index 0c44a8b..485a8fa 100644 (file)
@@ -8,16 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_VERSION:=20130302
+PKG_VERSION:=20130405
 PKG_RELEASE:=1
-PKG_REV:=a311c61dd664db7c1d16dd3395adf07bea6c141d
+PKG_REV:=f2f66ad7e805218468aa041985dccaf8719c296e
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
-PKG_MIRROR_MD5SUM:=d81d1b073521df0c608f42e2cedec60c
+PKG_MIRROR_MD5SUM:=5dff9bc3b8fbd9ef8a66273d5adee5a3
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
@@ -225,7 +225,9 @@ TARGET_CPPFLAGS := \
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
-TARGET_LDFLAGS += -lubox -lubus
+ifeq ($(findstring supplicant,$(BUILD_VARIANT)),)
+  TARGET_LDFLAGS += -lubox -lubus
+endif
 
 ifdef CONFIG_PACKAGE_kmod-mac80211
   TARGET_LDFLAGS += -lm -lnl-tiny