upgrade madwifi to r2756
[openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index 48a4e76..da8aac8 100644 (file)
@@ -1,28 +1,21 @@
-diff -ur madwifi.old/ath/if_ath.c madwifi.dev/ath/if_ath.c
---- madwifi.old/ath/if_ath.c   2007-02-20 22:50:52.277096688 +0100
-+++ madwifi.dev/ath/if_ath.c   2007-02-20 22:53:50.476006336 +0100
-@@ -72,7 +72,7 @@
+Index: madwifi-ng-r2756-20071018/ath/if_ath.c
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/ath/if_ath.c        2007-10-24 06:20:20.213841201 +0200
++++ madwifi-ng-r2756-20071018/ath/if_ath.c     2007-10-24 06:20:20.433853739 +0200
+@@ -75,7 +75,7 @@
  #include <net80211/if_llc.h>
  #endif
  
 -#define       AR_DEBUG
 +#undef        AR_DEBUG
  
- #include "if_athrate.h"
  #include "net80211/if_athproto.h"
-@@ -347,7 +347,7 @@
-               ath_keyprint(__func__, ix, hk, mac);            \
- } while (0)
- #else /* defined(AR_DEBUG) */
--#define       IFF_DUMPPKTS(sc, _m)    netif_msg_dumppkts(&sc->sc_ic)
-+#define       IFF_DUMPPKTS(sc, _m)
- #define       DPRINTF(sc, _m, _fmt, ...)
- #define       KEYPRINTF(sc, k, ix, mac)
- #endif /* defined(AR_DEBUG) */
-diff -ur madwifi.old/ath_rate/amrr/amrr.c madwifi.dev/ath_rate/amrr/amrr.c
---- madwifi.old/ath_rate/amrr/amrr.c   2007-02-20 22:50:52.278096536 +0100
-+++ madwifi.dev/ath_rate/amrr/amrr.c   2007-02-20 22:50:31.652232144 +0100
-@@ -67,7 +67,7 @@
+ #include "if_athvar.h"
+Index: madwifi-ng-r2756-20071018/ath_rate/amrr/amrr.c
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/ath_rate/amrr/amrr.c        2007-10-24 06:20:16.253615519 +0200
++++ madwifi-ng-r2756-20071018/ath_rate/amrr/amrr.c     2007-10-24 06:20:20.433853739 +0200
+@@ -70,7 +70,7 @@
  
  #include "amrr.h"
  
@@ -31,10 +24,24 @@ diff -ur madwifi.old/ath_rate/amrr/amrr.c madwifi.dev/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-diff -ur madwifi.old/ath_rate/onoe/onoe.c madwifi.dev/ath_rate/onoe/onoe.c
---- madwifi.old/ath_rate/onoe/onoe.c   2007-02-20 22:50:52.278096536 +0100
-+++ madwifi.dev/ath_rate/onoe/onoe.c   2007-02-20 22:50:31.653231992 +0100
-@@ -63,7 +63,7 @@
+Index: madwifi-ng-r2756-20071018/ath_rate/minstrel/minstrel.c
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/ath_rate/minstrel/minstrel.c        2007-10-24 06:20:18.217727448 +0200
++++ madwifi-ng-r2756-20071018/ath_rate/minstrel/minstrel.c     2007-10-24 06:20:20.441854191 +0200
+@@ -117,7 +117,7 @@
+ #include "minstrel.h"
+-#define       MINSTREL_DEBUG
++#undef        MINSTREL_DEBUG
+ #ifdef MINSTREL_DEBUG
+ enum {
+               ATH_DEBUG_RATE          = 0x00000010    /* rate control */
+Index: madwifi-ng-r2756-20071018/ath_rate/onoe/onoe.c
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/ath_rate/onoe/onoe.c        2007-10-24 06:20:16.269616432 +0200
++++ madwifi-ng-r2756-20071018/ath_rate/onoe/onoe.c     2007-10-24 06:20:20.445854420 +0200
+@@ -66,7 +66,7 @@
  
  #include "onoe.h"
  
@@ -43,10 +50,11 @@ diff -ur madwifi.old/ath_rate/onoe/onoe.c madwifi.dev/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-diff -ur madwifi.old/ath_rate/sample/sample.c madwifi.dev/ath_rate/sample/sample.c
---- madwifi.old/ath_rate/sample/sample.c       2007-02-20 22:50:52.278096536 +0100
-+++ madwifi.dev/ath_rate/sample/sample.c       2007-02-20 22:50:31.653231992 +0100
-@@ -65,7 +65,7 @@
+Index: madwifi-ng-r2756-20071018/ath_rate/sample/sample.c
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/ath_rate/sample/sample.c    2007-10-24 06:20:16.277616884 +0200
++++ madwifi-ng-r2756-20071018/ath_rate/sample/sample.c 2007-10-24 06:20:20.449854648 +0200
+@@ -68,7 +68,7 @@
  
  #include "sample.h"
  
@@ -54,22 +62,26 @@ diff -ur madwifi.old/ath_rate/sample/sample.c madwifi.dev/ath_rate/sample/sample
 +#undef        SAMPLE_DEBUG
  #ifdef SAMPLE_DEBUG
  enum {
-       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -ur madwifi.old/net80211/ieee80211_var.h madwifi.dev/net80211/ieee80211_var.h
---- madwifi.old/net80211/ieee80211_var.h       2007-02-20 22:50:52.279096384 +0100
-+++ madwifi.dev/net80211/ieee80211_var.h       2007-02-20 22:50:31.654231840 +0100
-@@ -37,7 +37,7 @@
- /*
-  * Definitions for IEEE 802.11 drivers.
-  */
+       ATH_DEBUG_NODE          = 0x00080000,   /* node management */
+Index: madwifi-ng-r2756-20071018/net80211/ieee80211_var.h
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/net80211/ieee80211_var.h    2007-10-24 06:20:16.285617342 +0200
++++ madwifi-ng-r2756-20071018/net80211/ieee80211_var.h 2007-10-24 06:20:20.453854879 +0200
+@@ -35,8 +35,8 @@
+ #ifndef _NET80211_IEEE80211_VAR_H_
+ #define _NET80211_IEEE80211_VAR_H_
 -#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
 +#undef        IEEE80211_DEBUG
- #undef        IEEE80211_DEBUG_REFCNT                  /* node refcnt stuff */
++#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
  
+ /* Definitions for IEEE 802.11 drivers. */
  #include <net80211/ieee80211_linux.h>
-diff -ur madwifi.old/tools/do_multi.c madwifi.dev/tools/do_multi.c
---- madwifi.old/tools/do_multi.c       2007-02-20 22:50:52.279096384 +0100
-+++ madwifi.dev/tools/do_multi.c       2007-02-20 22:50:31.654231840 +0100
+Index: madwifi-ng-r2756-20071018/tools/do_multi.c
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/tools/do_multi.c    2007-10-24 06:20:17.249672281 +0200
++++ madwifi-ng-r2756-20071018/tools/do_multi.c 2007-10-24 06:20:20.453854879 +0200
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -91,21 +103,22 @@ diff -ur madwifi.old/tools/do_multi.c madwifi.dev/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-diff -ur madwifi.old/tools/Makefile madwifi.dev/tools/Makefile
---- madwifi.old/tools/Makefile 2007-02-20 22:50:52.279096384 +0100
-+++ madwifi.dev/tools/Makefile 2007-02-20 22:50:31.654231840 +0100
-@@ -52,7 +52,7 @@
-       
- ifdef DOMULTI
- OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
--      athdebug.o 80211debug.o wlanconfig.o 
-+      wlanconfig.o 
- ALL=  ${OBJS} madwifi_multi
- endif
+Index: madwifi-ng-r2756-20071018/tools/Makefile
+===================================================================
+--- madwifi-ng-r2756-20071018.orig/tools/Makefile      2007-10-24 06:20:17.253672511 +0200
++++ madwifi-ng-r2756-20071018/tools/Makefile   2007-10-24 06:20:20.453854879 +0200
+@@ -48,7 +48,7 @@
  
-@@ -85,7 +85,7 @@
+ ALLPROGS=     athstats 80211stats athkey athchans athctrl \
+-      athdebug 80211debug wlanconfig ath_info
++      wlanconfig ath_info
+ OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
+ ALL=  ${OBJS} madwifi_multi
+@@ -84,7 +84,7 @@
        ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
- madwifi_multi:
+ madwifi_multi: $(OBJS)
        ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
 -      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
 +      for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \