update madwifi to latest rev - works around some crashiness
[openwrt.git] / package / madwifi / patches / 102-multicall_binary.patch
index e5eb0d2..e70e24c 100644 (file)
@@ -1,7 +1,7 @@
-Index: madwifi-ng-r2799-20071030/tools/80211debug.c
+Index: madwifi-ng-r2834-20071106/tools/80211debug.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/80211debug.c  2007-10-31 14:04:46.925295598 +0100
-+++ madwifi-ng-r2799-20071030/tools/80211debug.c       2007-10-31 14:04:47.537330476 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/80211debug.c  2007-11-07 14:01:59.745356362 +0100
++++ madwifi-ng-r2834-20071106/tools/80211debug.c       2007-11-07 14:02:00.181381212 +0100
 @@ -49,6 +49,10 @@
  #include <getopt.h>
  #include <err.h>
@@ -33,10 +33,10 @@ Index: madwifi-ng-r2799-20071030/tools/80211debug.c
        const char *ifname = "ath0";
        const char *cp, *tp;
        const char *sep;
-Index: madwifi-ng-r2799-20071030/tools/80211stats.c
+Index: madwifi-ng-r2834-20071106/tools/80211stats.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/80211stats.c  2007-10-31 14:04:46.929295827 +0100
-+++ madwifi-ng-r2799-20071030/tools/80211stats.c       2007-10-31 14:04:47.537330476 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/80211stats.c  2007-11-07 14:01:59.753356821 +0100
++++ madwifi-ng-r2834-20071106/tools/80211stats.c       2007-11-07 14:02:00.181381212 +0100
 @@ -60,6 +60,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
@@ -68,10 +68,10 @@ Index: madwifi-ng-r2799-20071030/tools/80211stats.c
        int c, len;
        struct ieee80211req_sta_info *si;
        u_int8_t buf[24*1024], *cp;
-Index: madwifi-ng-r2799-20071030/tools/athchans.c
+Index: madwifi-ng-r2834-20071106/tools/athchans.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/athchans.c    2007-10-31 14:04:46.937296283 +0100
-+++ madwifi-ng-r2799-20071030/tools/athchans.c 2007-10-31 14:04:47.545330932 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/athchans.c    2007-11-07 14:01:59.757357047 +0100
++++ madwifi-ng-r2834-20071106/tools/athchans.c 2007-11-07 14:02:00.189381667 +0100
 @@ -59,6 +59,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
@@ -104,10 +104,10 @@ Index: madwifi-ng-r2799-20071030/tools/athchans.c
        const char *ifname = "wifi0";
        struct ieee80211req_chanlist chanlist;
        int c;
-Index: madwifi-ng-r2799-20071030/tools/athctrl.c
+Index: madwifi-ng-r2834-20071106/tools/athctrl.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/athctrl.c     2007-10-31 14:04:46.945296738 +0100
-+++ madwifi-ng-r2799-20071030/tools/athctrl.c  2007-10-31 14:04:47.549331161 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/athctrl.c     2007-11-07 14:01:59.765357502 +0100
++++ madwifi-ng-r2834-20071106/tools/athctrl.c  2007-11-07 14:02:00.193381896 +0100
 @@ -53,6 +53,10 @@
  
  #include <net/if.h>
@@ -139,10 +139,10 @@ Index: madwifi-ng-r2799-20071030/tools/athctrl.c
        char device[IFNAMSIZ + 1];
        int distance = -1;
        int c;
-Index: madwifi-ng-r2799-20071030/tools/athdebug.c
+Index: madwifi-ng-r2834-20071106/tools/athdebug.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/athdebug.c    2007-10-31 14:04:46.953297193 +0100
-+++ madwifi-ng-r2799-20071030/tools/athdebug.c 2007-10-31 14:04:47.557331616 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/athdebug.c    2007-11-07 14:01:59.773357960 +0100
++++ madwifi-ng-r2834-20071106/tools/athdebug.c 2007-11-07 14:02:00.193381896 +0100
 @@ -52,6 +52,10 @@
  #include <getopt.h>
  #include <err.h>
@@ -175,10 +175,10 @@ Index: madwifi-ng-r2799-20071030/tools/athdebug.c
  #ifdef __linux__
        const char *ifname = "wifi0";
  #else
-Index: madwifi-ng-r2799-20071030/tools/athkey.c
+Index: madwifi-ng-r2834-20071106/tools/athkey.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/athkey.c      2007-10-31 14:04:46.957297422 +0100
-+++ madwifi-ng-r2799-20071030/tools/athkey.c   2007-10-31 14:04:47.557331616 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/athkey.c      2007-11-07 14:01:59.777358186 +0100
++++ madwifi-ng-r2834-20071106/tools/athkey.c   2007-11-07 14:02:00.193381896 +0100
 @@ -59,6 +59,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
@@ -210,10 +210,10 @@ Index: madwifi-ng-r2799-20071030/tools/athkey.c
        const char *ifname = "wifi0";
        struct ieee80211req_key setkey;
        struct ieee80211req_del_key delkey;
-Index: madwifi-ng-r2799-20071030/tools/athstats.c
+Index: madwifi-ng-r2834-20071106/tools/athstats.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/athstats.c    2007-10-31 14:04:46.965297878 +0100
-+++ madwifi-ng-r2799-20071030/tools/athstats.c 2007-10-31 14:04:47.557331616 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/athstats.c    2007-11-07 14:01:59.785358642 +0100
++++ madwifi-ng-r2834-20071106/tools/athstats.c 2007-11-07 14:02:00.193381896 +0100
 @@ -63,6 +63,10 @@
  #include "wireless_copy.h"
  #include "if_athioctl.h"
@@ -246,10 +246,10 @@ Index: madwifi-ng-r2799-20071030/tools/athstats.c
  #ifdef __linux__
        const char *ifname = "wifi0";
  #else
-Index: madwifi-ng-r2799-20071030/tools/do_multi.c
+Index: madwifi-ng-r2834-20071106/tools/do_multi.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-ng-r2799-20071030/tools/do_multi.c 2007-10-31 14:04:47.557331616 +0100
++++ madwifi-ng-r2834-20071106/tools/do_multi.c 2007-11-07 14:02:00.197382122 +0100
 @@ -0,0 +1,32 @@
 +#include <string.h>
 +#include "do_multi.h"
@@ -283,10 +283,10 @@ Index: madwifi-ng-r2799-20071030/tools/do_multi.c
 +
 +    return ret;
 +}
-Index: madwifi-ng-r2799-20071030/tools/do_multi.h
+Index: madwifi-ng-r2834-20071106/tools/do_multi.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-ng-r2799-20071030/tools/do_multi.h 2007-10-31 14:04:47.557331616 +0100
++++ madwifi-ng-r2834-20071106/tools/do_multi.h 2007-11-07 14:02:00.197382122 +0100
 @@ -0,0 +1,10 @@
 +
 +int a80211debug_init(int argc, char *argv[]);
@@ -298,10 +298,10 @@ Index: madwifi-ng-r2799-20071030/tools/do_multi.h
 +int athstats_init(int argc, char *argv[]);
 +int wlanconfig_init(int argc, char *argv[]);
 +int athinfo_init(int argc, char *argv[]);
-Index: madwifi-ng-r2799-20071030/tools/Makefile
+Index: madwifi-ng-r2834-20071106/tools/Makefile
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/Makefile      2007-10-31 14:04:46.981298791 +0100
-+++ madwifi-ng-r2799-20071030/tools/Makefile   2007-10-31 14:04:47.561331846 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/Makefile      2007-11-07 14:01:59.801359556 +0100
++++ madwifi-ng-r2834-20071106/tools/Makefile   2007-11-07 14:02:00.197382122 +0100
 @@ -47,9 +47,12 @@
  endif
  
@@ -367,10 +367,10 @@ Index: madwifi-ng-r2799-20071030/tools/Makefile
  
  install: $(ALL) 
        install -d $(DESTDIR)$(BINDIR)
-Index: madwifi-ng-r2799-20071030/tools/wlanconfig.c
+Index: madwifi-ng-r2834-20071106/tools/wlanconfig.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/wlanconfig.c  2007-10-31 14:04:46.989299247 +0100
-+++ madwifi-ng-r2799-20071030/tools/wlanconfig.c       2007-10-31 14:04:47.561331846 +0100
+--- madwifi-ng-r2834-20071106.orig/tools/wlanconfig.c  2007-11-07 14:01:59.809360011 +0100
++++ madwifi-ng-r2834-20071106/tools/wlanconfig.c       2007-11-07 14:02:00.197382122 +0100
 @@ -62,6 +62,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
@@ -402,11 +402,11 @@ Index: madwifi-ng-r2799-20071030/tools/wlanconfig.c
        const char *ifname, *cmd;
        unsigned char bnounit = 0;
        char *if_base = NULL;
-Index: madwifi-ng-r2799-20071030/tools/ath_info.c
+Index: madwifi-ng-r2834-20071106/tools/ath_info.c
 ===================================================================
---- madwifi-ng-r2799-20071030.orig/tools/ath_info.c    2007-10-31 14:04:46.997299702 +0100
-+++ madwifi-ng-r2799-20071030/tools/ath_info.c 2007-10-31 14:04:47.561331846 +0100
-@@ -722,8 +722,13 @@
+--- madwifi-ng-r2834-20071106.orig/tools/ath_info.c    2007-11-07 14:01:59.817360466 +0100
++++ madwifi-ng-r2834-20071106/tools/ath_info.c 2007-11-07 14:02:00.201382352 +0100
+@@ -736,7 +736,12 @@
                "unlawful radio transmissions!\n\n");
  }
  
@@ -414,8 +414,7 @@ Index: madwifi-ng-r2799-20071030/tools/ath_info.c
 +int
 +athinfo_init(int argc, char *argv[])
 +#else
- int
- main(int argc, char *argv[])
+ int main(int argc, char *argv[])
 +#endif
  {
        u_int32_t dev_addr;