mac80211: update to wireless-testing 2010-04-21
[openwrt.git] / package / mac80211 / Makefile
index d586e05..d0b8976 100644 (file)
@@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mac80211
 
-PKG_VERSION:=2010-04-13
+PKG_VERSION:=2010-04-21
 PKG_RELEASE:=1
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 #      http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/11 \
 #      http://wireless.kernel.org/download/compat-wireless-2.6
-PKG_MD5SUM:=d70715219e37214463c0e08974db80c1
+PKG_MD5SUM:=dfefd51780fa1045edd1084efeab8b1e
 
 PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
@@ -423,19 +423,9 @@ define KernelPackage/ath9k/config
        menu "Configuration"
                depends PACKAGE_kmod-ath9k
 
-       config PACKAGE_ATH9K_DEBUG
-               bool "ath9k debugging"
-               depends KERNEL_DEBUG_FS
-               help
-                 Say Y, if you need ath9k to display debug messages.
-                 Pass the debug mask as a module parameter:
-
-                 modprobe ath9k debug=0x00002000
-
-                 Look in ath9k/core.h for possible debug masks
-
        config PACKAGE_ATH9K_USE_MINSTREL
                bool "use the new minstrel_ht rate control for ath9k"
+               default y
 
        endmenu
 endef
@@ -542,6 +532,20 @@ define KernelPackage/net-ipw2200/description
  - ipw2200
 endef
 
+
+define KernelPackage/mwl8k
+  $(call KernelPackage/mac80211/Default)
+  TITLE:=Driver for Marvell TOPDOG 802.11 Wireless cards
+  URL:=http://wireless.kernel.org/en/users/Drivers/mwl8k
+  DEPENDS+= @PCI_SUPPORT +kmod-mac80211
+  FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/mwl8k.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,27,mwl8k)
+endef
+
+define KernelPackage/mwl8k/description
+ Kernel modules for Marvell TOPDOG 802.11 Wireless cards
+endef
+
 #Broadcom firmware
 ifneq ($(CONFIG_B43_EXPERIMENTAL),)
   PKG_B43_FWV4_NAME:=broadcom-wl
@@ -863,7 +867,7 @@ MAKE_OPTS:= \
        CONFIG_LIB80211_CRYPT_TKIP= \
        CONFIG_IWLWIFI= \
        CONFIG_IWLAGN= \
-       CONFIG_MWL8K= \
+       CONFIG_MWL8K=$(if $(CONFIG_PACKAGE_kmod-mwl8k),m) \
        CONFIG_ATMEL= \
        CONFIG_PCMCIA_ATMEL= \
        CONFIG_ADM8211= \
@@ -1062,3 +1066,4 @@ $(eval $(call KernelPackage,b43legacy))
 $(eval $(call KernelPackage,net-libipw))
 $(eval $(call KernelPackage,net-ipw2100))
 $(eval $(call KernelPackage,net-ipw2200))
+$(eval $(call KernelPackage,mwl8k))