Use $(CP) instead of $(INSTALL_BIN) for binaries.
[openwrt.git] / package / linux-atm / Makefile
index 000ea5c..f67294e 100644 (file)
@@ -41,6 +41,11 @@ define Package/atm-tools/description
   This package contains the Linux ATM tools.
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(INSTALL_BIN) $(SCRIPT_DIR)/config.sub $(SCRIPT_DIR)/config.guess $(PKG_BUILD_DIR)/
+endef
+
 define Build/Configure
        $(call Build/Configure/Default)
        # prevent autoheader invocation
@@ -76,7 +81,7 @@ endef
 
 define Package/atm-tools/install
        $(INSTALL_DIR) $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/atmarp{,d} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmarp{,d} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/ipoa.sh $(1)/lib/network/
 endef