ncurses: Fix build of libncursew
[openwrt.git] / package / libs / ncurses / Makefile
index 26b7bf5..924033f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,20 +9,23 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncurses
 PKG_VERSION:=5.9
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/ncurses
 PKG_MD5SUM:=8cb9c412e5f2d96bc6f459aa8c6282a1
 
-PKG_LICENSE:=FREE
+PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=README
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
+PKG_BUILD_DEPENDS:=ncurses/host
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/libncurses
   SECTION:=libs
@@ -58,8 +61,10 @@ CONFIGURE_ARGS += \
        --disable-rpath \
        --without-ada \
        --without-debug \
+       --without-manpages \
        --without-profile \
        --without-progs \
+       --without-tests \
        --disable-big-core \
        --disable-home-terminfo \
        --with-normal \
@@ -67,6 +72,17 @@ CONFIGURE_ARGS += \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
+HOST_CONFIGURE_ARGS += \
+       --without-cxx \
+       --without-cxx-binding \
+       --without-ada \
+       --without-debug \
+       --without-manpages \
+       --without-profile \
+       --without-tests \
+       --without-curses-h
+
+
 ifeq ($(HOST_OS),FreeBSD)
        CONFIGURE_ARGS +=
                --with-terminfo=/usr/share/terminfo.db 
@@ -75,6 +91,7 @@ endif
 ifeq ($(BUILD_VARIANT),libncursesw)
        CONFIGURE_ARGS += \
                --enable-widec \
+               --includedir="/usr/include/ncursesw" \
                --with-build-cppflags=-D_GNU_SOURCE
 endif
 
@@ -122,7 +139,7 @@ endef
 ifeq ($(BUILD_VARIANT),libncursesw)
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/ncursesw/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/ncursesw/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ncursesw/*.h $(1)/usr/include/ncursesw/
 
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel,menu,form}w.{a,so*} $(1)/usr/lib/
@@ -149,6 +166,17 @@ define Build/InstallDev
 endef
 endif
 
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) libs
+       $(MAKE) -C $(HOST_BUILD_DIR)/progs tic
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/progs/tic $(STAGING_DIR_HOST)/bin/tic
+endef
+
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,terminfo))
 $(eval $(call BuildPackage,libncurses))
 $(eval $(call BuildPackage,libncursesw))