rpcd: iwinfo plugin fixes
[openwrt.git] / package / libs / gettext-full / Makefile
index 2ae8cd3..e525d30 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext-full
-PKG_VERSION:=0.18.1.1
+PKG_VERSION:=0.19.6
 PKG_RELEASE:=2
 
-PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
+PKG_MD5SUM:=69d79254ee3b41df23f41c2f4fd720d9
 PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=GPL-3.0+
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
@@ -35,6 +36,12 @@ define Package/libintl-full
 endef
 
 TARGET_CFLAGS += $(FPIC)
+ifneq ($(HOST_OS),Linux)
+  TARGET_CFLAGS += -I$(STAGING_DIR)/host/include
+endif
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -D__UCLIBC__
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -44,11 +51,15 @@ CONFIGURE_ARGS += \
        --disable-java \
        --disable-native-java \
        --disable-openmp \
+       --disable-curses \
        --with-included-gettext \
        --without-libintl-prefix \
        --without-libexpat-prefix \
        --without-emacs
 
+HOST_CONFIGURE_ARGS += \
+       --with-included-libxml --without-libxml2-prefix --with-included-libcroco
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/libintl-full/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/lib/libintl-full/include/