gettext-full: use portability header files for byteswapping on non-linux systems
[openwrt.git] / package / libs / gettext-full / Makefile
index 7b640e6..11dc1f5 100644 (file)
@@ -35,6 +35,9 @@ define Package/libintl-full
 endef
 
 TARGET_CFLAGS += $(FPIC)
+ifneq ($(HOST_OS),Linux)
+  TARGET_CFLAGS += -I$(STAGING_DIR_HOST)/include
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \