Change order of module startup to force USB2 before USB1.1
[openwrt.git] / package / kernel / modules / usb.mk
index 04363d2..0f95ad8 100644 (file)
@@ -140,7 +140,7 @@ define KernelPackage/usb2
   TITLE:=Support for USB2 controllers
   KCONFIG:=CONFIG_USB_EHCI_HCD
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-hcd.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,ehci-hcd)
+  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd)
 endef
 
 define KernelPackage/usb2/description
@@ -579,7 +579,7 @@ define KernelPackage/usb-net-hso
   TITLE:=Kernel module for Option USB High Speed Mobile Devices
   KCONFIG:= \
        CONFIG_RFKILL \
-       CONFIG_RFKILL_INPUT
+       CONFIG_RFKILL_INPUT \
        CONFIG_USB_HSO
   FILES:= \
        $(LINUX_DIR)/net/rfkill/rfkill.$(LINUX_KMOD_SUFFIX) \
@@ -682,3 +682,16 @@ endef
 
 $(eval $(call KernelPackage,usb-test))
 
+define KernelPackage/usb-phidget
+  $(call usbdep,@LINUX_2_6)
+  TITLE:=USB Phidget Driver
+  KCONFIG:=CONFIG_USB_PHIDGET CONFIG_USB_PHIDGETKIT CONFIG_USB_PHIDGETMOTORCONTROL CONFIG_USB_PHIDGETSERVO
+  FILES:=$(LINUX_DIR)/drivers/usb/misc/phidget*.ko
+endef
+
+define KernelPackage/usb-phidget/description
+ Kernel support for USB Phidget devices.
+endef
+
+$(eval $(call KernelPackage,usb-phidget))
+