kernel: remove more unnecessary kernel version checks/dependencies
[openwrt.git] / package / kernel / modules / other.mk
index 9e4559a..1bf1755 100644 (file)
@@ -132,34 +132,13 @@ endef
 $(eval $(call KernelPackage,eeprom-at25))
 
 
-define KernelPackage/gpio-cs5535
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=AMD CS5535/CS5536 GPIO driver
-  DEPENDS:=@TARGET_x86 @LINUX_2_6_37
-  KCONFIG:=CONFIG_CS5535_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
-endef
-
-define KernelPackage/gpio-cs5535/description
- This package contains the AMD CS5535/CS5536 GPIO driver
-endef
-
-$(eval $(call KernelPackage,gpio-cs5535))
-
-
 define KernelPackage/gpio-cs5535-new
   SUBMENU:=$(OTHER_MENU)
   TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
   DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
   KCONFIG:=CONFIG_GPIO_CS5535
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
   FILES:=$(LINUX_DIR)/drivers/gpio/gpio-cs5535.ko
   AUTOLOAD:=$(call AutoLoad,50,gpio-cs5535)
-else
-  FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
-  AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
-endif
 endef
 
 define KernelPackage/gpio-cs5535-new/description
@@ -752,34 +731,6 @@ endef
 
 $(eval $(call KernelPackage,pwm-gpio))
 
-define KernelPackage/rtc-core-2.6
-  SUBMENU:=$(OTHER_MENU)
-  DEPENDS:=@(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
-  TITLE:=Real Time Clock class support
-  KCONFIG:=CONFIG_RTC_CLASS
-  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-core.ko
-  AUTOLOAD:=$(call AutoLoad,29,rtc-core)
-endef
-
-define KernelPackage/rtc-core-2.6/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-2.6))
-
-define KernelPackage/rtc-core-3.x
-  SUBMENU:=$(OTHER_MENU)
-  DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
-  TITLE:=Real Time Clock class support
-  KCONFIG:=CONFIG_RTC_CLASS=y
-endef
-
-define KernelPackage/rtc-core-3.x/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-3.x))
-
 define KernelPackage/rtc-pcf8563
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Philips PCF8563/Epson RTC8564 RTC support
@@ -869,7 +820,7 @@ $(eval $(call KernelPackage,mtdtests))
 define KernelPackage/nand
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NAND flash support
-  DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
+  DEPENDS:=@!LINUX_2_6_39
   KCONFIG:=CONFIG_MTD_NAND \
        CONFIG_MTD_NAND_IDS \
        CONFIG_MTD_NAND_ECC
@@ -890,7 +841,7 @@ $(eval $(call KernelPackage,nand))
 define KernelPackage/nandsim
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NAND simulator
-  DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39) +kmod-nand
+  DEPENDS:=+kmod-nand
   KCONFIG:=CONFIG_MTD_NAND_NANDSIM
   FILES:=$(LINUX_DIR)/drivers/mtd/nand/nandsim.ko
 endef
@@ -912,11 +863,7 @@ define KernelPackage/serial-8250
        CONFIG_SERIAL_8250_SHARE_IRQ=y \
        CONFIG_SERIAL_8250_DETECT_IRQ=n \
        CONFIG_SERIAL_8250_RSA=n
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
   FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
-else
-  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
-endif
 endef
 
 define KernelPackage/serial-8250/description