[kernel] add missing autoload shortcut to crypto modules for btrfs
[openwrt.git] / package / kernel / modules / crypto.mk
index 5459de3..ef41d6f 100644 (file)
@@ -29,7 +29,7 @@ define KernelPackage/crypto-core
        CONFIG_CRYPTO_ALGAPI \
        $(foreach mod,$(CRYPTO_MODULES),$(call crypto_confvar,$(mod)))
   FILES:=$(foreach mod,$(CRYPTO_MODULES),$(call crypto_file,$(mod)))
-  AUTOLOAD:=$(call AutoLoad,01,$(foreach mod,$(CRYPTO_MODULES),$(call crypto_name,$(mod))))
+  AUTOLOAD:=$(call AutoLoad,01,$(foreach mod,$(CRYPTO_MODULES),$(call crypto_name,$(mod))),1)
 endef
 $(eval $(call KernelPackage,crypto-core))
 
@@ -43,7 +43,7 @@ define KernelPackage/crypto-hash
   TITLE:=CryptoAPI hash support
   KCONFIG:=CONFIG_CRYPTO_HASH2
   FILES:=$(LINUX_DIR)/crypto/crypto_hash.ko
-  AUTOLOAD:=$(call AutoLoad,02,crypto_hash)
+  AUTOLOAD:=$(call AutoLoad,02,crypto_hash,1)
   $(call AddDepends/crypto)
 endef
 $(eval $(call KernelPackage,crypto-hash))