kernel: add usb-net-sr9700 package
[openwrt.git] / package / kernel / linux / modules / usb.mk
index 598ba4a..1fdf746 100644 (file)
@@ -486,11 +486,9 @@ define KernelPackage/usb-dwc2
        CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n \
        CONFIG_USB_DWC2_DEBUG_PERIODIC=n
   FILES:= \
-       $(LINUX_DIR)/drivers/usb/dwc2/dwc2.ko
-  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko),)
-    FILES+=$(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko
-  endif
-  AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform,1)
+       $(LINUX_DIR)/drivers/usb/dwc2/dwc2.ko \
+       $(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko@lt4.3
+  AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform@lt4.3,1)
   $(call AddDepends/usb)
 endef
 
@@ -1317,6 +1315,21 @@ endef
 $(eval $(call KernelPackage,usb-net-rtl8152))
 
 
+define KernelPackage/usb-net-sr9700
+  TITLE:=Support for CoreChip SR9700 ethernet devices
+  KCONFIG:=CONFIG_USB_NET_SR9700
+  FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/sr9700.ko
+  AUTOLOAD:=$(call AutoProbe,sr9700)
+  $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-sr9700/description
+ Kernel module for CoreChip-sz SR9700 based USB 1.1 10/100 ethernet devices
+endef
+
+$(eval $(call KernelPackage,usb-net-sr9700))
+
+
 define KernelPackage/usb-net-rndis
   TITLE:=Support for RNDIS connections
   KCONFIG:=CONFIG_USB_NET_RNDIS_HOST