kernel: be consistent with formatting style
[openwrt.git] / package / kernel / linux / modules / input.mk
index 78fa924..1daaad3 100644 (file)
@@ -32,7 +32,7 @@ define KernelPackage/hid-generic
 endef
 
 define KernelPackage/hid/description
 Kernel modules for generic HID device (e.g. keyboards and mice) support
+ Kernel modules for generic HID device (e.g. keyboards and mice) support
 endef
 
 $(eval $(call KernelPackage,hid-generic))
@@ -68,24 +68,6 @@ endef
 $(eval $(call KernelPackage,input-evdev))
 
 
-define KernelPackage/input-gpio-buttons
-  SUBMENU:=$(INPUT_MODULES_MENU)
-  TITLE:=Polled GPIO buttons input device
-  DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
-  KCONFIG:= \
-       CONFIG_INPUT_GPIO_BUTTONS \
-       CONFIG_INPUT_MISC=y
-  FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_buttons,1)
-endef
-
-define KernelPackage/input-gpio-buttons/description
- Kernel module for support polled GPIO buttons input device
-endef
-
-$(eval $(call KernelPackage,input-gpio-buttons))
-
-
 define KernelPackage/input-gpio-keys
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=GPIO key support
@@ -151,7 +133,7 @@ define KernelPackage/input-joydev
 endef
 
 define KernelPackage/input-joydev/description
 Kernel module for joystick support
+ Kernel module for joystick support
 endef
 
 $(eval $(call KernelPackage,input-joydev))
@@ -174,17 +156,17 @@ $(eval $(call KernelPackage,input-polldev))
 
 
 define KernelPackage/input-matrixkmap
-   SUBMENU:=$(INPUT_MODULES_MENU)
-   TITLE:=Input matrix devices support
-   KCONFIG:=CONFIG_INPUT_MATRIXKMAP
-   DEPENDS:=@!LINUX_3_3
-   FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
-   AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
-   $(call AddDepends/input)
+  SUBMENU:=$(INPUT_MODULES_MENU)
+  TITLE:=Input matrix devices support
+  KCONFIG:=CONFIG_INPUT_MATRIXKMAP
+  DEPENDS:=@!LINUX_3_3
+  FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
+  AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
+  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-matrix/description
 Kernel module support for input matrix devices
+ Kernel module support for input matrix devices
 endef
 
 $(eval $(call KernelPackage,input-matrixkmap))