package/kernel: add package for the Freescale On-Chip EHCI Controller
[openwrt.git] / package / kernel / Makefile
index f440a40..d44b5a7 100644 (file)
@@ -9,9 +9,13 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
+PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-SCAN_DEPS=modules/*.mk
+SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
@@ -34,7 +38,7 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
+  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)
   URL:=http://www.kernel.org/
 endef
 
@@ -44,5 +48,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include ./modules/*.mk
+include $(sort $(wildcard ./modules/*.mk))
 -include $(TOPDIR)/target/linux/*/modules.mk