package/kernel: select crypto-sha256 for cifs on 3.7+
[openwrt.git] / package / kernel / Makefile
index 036af76..d44b5a7 100644 (file)
@@ -1,18 +1,21 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
+PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-SCAN_DEPS=modules/*.mk
+SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
@@ -35,7 +38,8 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)
+  URL:=http://www.kernel.org/
 endef
 
 define Package/kernel/install
@@ -44,5 +48,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include $(TOPDIR)/target/linux/*/modules.mk
-include ./modules/*.mk
+include $(sort $(wildcard ./modules/*.mk))
+-include $(TOPDIR)/target/linux/*/modules.mk