fix iptables extension issue with mac os x builds
[openwrt.git] / package / iptables / Makefile
index 1b6bfc0..5c65e68 100644 (file)
@@ -19,15 +19,12 @@ PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
 PKG_MD5SUM:=00fb916fa8040ca992a5ace56d905ea5
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
   include $(INCLUDE_DIR)/netfilter.mk
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep 'NETFILTER' $(LINUX_DIR)/.config | md5s)
 endif
 
 define Package/iptables/Default
@@ -164,6 +161,9 @@ define Package/ip6tables
 endef
 
 define Build/Configure
+       rm -f $(PKG_BUILD_DIR)/.configured*
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               clean
 endef
 
 define Build/Compile
@@ -172,6 +172,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                COPT_FLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="-rdynamic -static-libgcc" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install