[base-files] Don't do lazy unmounting of filessystems at reboot/poweroff.
[openwrt.git] / package / iproute2 / Makefile
index f829293..a3b5f47 100644 (file)
@@ -1,24 +1,46 @@
-# $Id$
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=2.6.15-060110
+PKG_VERSION:=2.6.29-1
 PKG_RELEASE:=1
-PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
 
-PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
+PKG_MD5SUM:=c1bc258a6c345905e79935ac7a3cc582
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
-PKG_CAT:=zcat
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/iproute2/Default
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=http://linux-net.osdl.org/index.php/Iproute2
+endef
+
+define Package/ip
+$(call Package/iproute2/Default)
+  TITLE:=Routing control utility
+endef
 
-$(eval $(call PKG_template,IP,ip,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,TC,tc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+define Package/tc
+$(call Package/iproute2/Default)
+  TITLE:=Traffic control utility
+endef
 
-$(PKG_BUILD_DIR)/.configured:
-       $(SED) "s:-O2:${TARGET_CFLAGS}:g" $(PKG_BUILD_DIR)/Makefile
+define Package/genl
+$(call Package/iproute2/Default)
+  TITLE:=General netlink utility frontend
+endef
+
+define Build/Configure
        $(SED) "s,-I/usr/include/db3,," $(PKG_BUILD_DIR)/Makefile
        $(SED) "s,^KERNEL_INCLUDE.*,KERNEL_INCLUDE=$(LINUX_DIR)/include," \
                $(PKG_BUILD_DIR)/Makefile
@@ -27,22 +49,45 @@ $(PKG_BUILD_DIR)/.configured:
        # For now disable compiling of the misc directory because it seems to fail
        rm -rf $(PKG_BUILD_DIR)/misc 
        $(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC=$(HOSTCC) CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
-       touch $@
-
-$(IPKG_IP):
-       mkdir -p $(IDIR_IP)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/ip/ip $(IDIR_IP)/usr/sbin/
-       $(STRIP) $(IDIR_IP)/usr/sbin/*
-       $(IPKG_BUILD) $(IDIR_IP) $(PACKAGE_DIR)
-
-$(IPKG_TC):
-       mkdir -p $(IDIR_TC)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/tc/tc $(IDIR_TC)/usr/sbin/
-       $(STRIP) $(IDIR_TC)/usr/sbin/*
-       $(IPKG_BUILD) $(IDIR_TC) $(PACKAGE_DIR)
+endef
+
+MAKE_FLAGS += \
+       EXTRA_CCOPTS="$(TARGET_CFLAGS)" \
+       KERNEL_INCLUDE="$(LINUX_DIR)/include" \
+       FPIC="$(FPIC)" \
+       all tc/tc ip/ip
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
+       $(Build/Compile/Default)
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/include/libnetlink.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
+endef
+
+define Package/ip/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/iproute2
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
+endef
+
+define Package/tc/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
+endef
+
+define Package/genl/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,ip))
+$(eval $(call BuildPackage,tc))
+$(eval $(call BuildPackage,genl))
+