[base-files] Don't do lazy unmounting of filessystems at reboot/poweroff.
[openwrt.git] / package / iproute2 / Makefile
index d21a92c..a3b5f47 100644 (file)
@@ -4,36 +4,43 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=2.6.15-060110
+PKG_VERSION:=2.6.29-1
 PKG_RELEASE:=1
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
+PKG_MD5SUM:=c1bc258a6c345905e79935ac7a3cc582
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
-PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/iproute2/Default
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=http://linux-net.osdl.org/index.php/Iproute2
+endef
+
 define Package/ip
-SECTION:=base
-CATEGORY:=Network
-DEPENDS:=iproute2
-TITLE:=A routing control utility
+$(call Package/iproute2/Default)
+  TITLE:=Routing control utility
 endef
 
 define Package/tc
-$(call Package/ip)
-TITLE:=A traffic control utility
+$(call Package/iproute2/Default)
+  TITLE:=Traffic control utility
+endef
+
+define Package/genl
+$(call Package/iproute2/Default)
+  TITLE:=General netlink utility frontend
 endef
 
 define Build/Configure
-       $(SED) "s:-O2:${TARGET_CFLAGS}:g" $(PKG_BUILD_DIR)/Makefile
        $(SED) "s,-I/usr/include/db3,," $(PKG_BUILD_DIR)/Makefile
        $(SED) "s,^KERNEL_INCLUDE.*,KERNEL_INCLUDE=$(LINUX_DIR)/include," \
                $(PKG_BUILD_DIR)/Makefile
@@ -44,20 +51,43 @@ define Build/Configure
        $(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
 endef
 
+MAKE_FLAGS += \
+       EXTRA_CCOPTS="$(TARGET_CFLAGS)" \
+       KERNEL_INCLUDE="$(LINUX_DIR)/include" \
+       FPIC="$(FPIC)" \
+       all tc/tc ip/ip
+
 define Build/Compile
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC=$(HOSTCC) CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
+       $(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
+       $(Build/Compile/Default)
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/include/libnetlink.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
 endef
 
 define Package/ip/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/iproute2
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
 endef
 
 define Package/tc/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
+endef
+
+define Package/genl/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
+$(eval $(call BuildPackage,genl))
+
+