Use $(CP) instead of $(INSTALL_BIN) for binaries.
[openwrt.git] / package / gdbserver / Makefile
index 7e5d33b..e8fb2ee 100644 (file)
@@ -1,3 +1,8 @@
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -6,22 +11,23 @@ PKG_NAME:=gdbserver
 PKG_VERSION:=6.3
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+GDB_DIR:=$(BUILD_DIR_TOOLCHAIN)/gdb-$(PKG_VERSION)
 
-GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(PKG_VERSION)
+include $(INCLUDE_DIR)/package.mk
 
-include $(TOPDIR)/package/rules.mk
+define Package/gdbserver
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@GDB
+  TITLE:=Remote Server for the GNU Debugger
+endef
 
-$(eval $(call PKG_template,GDBSERVER,gdbserver,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+define Package/gdbserver/description
+ GDBSERVER is a program that allows you to run GDB on a different machine 
+ than the one which is running the program being debugged.
+endef
 
-
-$(PKG_BUILD_DIR)/.prepared:
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
-       touch $@
-
-$(PKG_BUILD_DIR)/.configured:
+define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -44,19 +50,20 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_NLS) \
                  $(DISABLE_LARGEFILE) \
        );
-       touch $@
+endef
 
-$(PKG_BUILD_DIR)/.built:
+define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
-       touch $@
+endef
+
+define Package/gdbserver/install       
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
+endef
 
-$(IPKG_GDBSERVER):
-       install -m0755 -d $(IDIR_GDBSERVER)/usr/bin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(IDIR_GDBSERVER)/usr/bin/
-       $(RSTRIP) $(IDIR_GDBSERVER)
-       $(IPKG_BUILD) $(IDIR_GDBSERVER) $(PACKAGE_DIR)
+$(eval $(call BuildPackage,gdbserver))