finally move buildroot-ng to trunk
[openwrt.git] / package / ebtables / Makefile
index 04adbf6..a0e53a4 100644 (file)
@@ -1,33 +1,43 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ebtables
-PKG_VERSION:=2.0.6
+PKG_VERSION:=2.0.8-rc2
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=c4559af2366c764c6c42a3fdd40d60d3
+PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
 PKG_CAT:=zcat
 
-include $(TOPDIR)/package/rules.mk
+PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
 
 define Package/ebtables
-SECTION:=base
-CATEGORY:=Network
-DEFAULT:=y
-TITLE:=Ethernet bridge firewall administration utility
-DESCRIPTION:=Ethernet Bridge Firewalling (ebtables)
-URL:=http://ebtables.sourceforge.net/
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Ethernet bridge firewall administration utility
+  URL:=http://ebtables.sourceforge.net/
 endef
 
 define Package/ebtables/install
-       install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/ebtables
-       $(RSTRIP) $(IDIR_EBTABLES)
-       $(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)
-ended
+       install -d -m0755 $(1)/etc
+       install -m0644 $(PKG_BUILD_DIR)/ethertypes $(1)/etc/
+       install -d -m0755 $(1)/usr/lib/ebtables
+       install -m0755 $(PKG_BUILD_DIR)/lib*.so $(1)/usr/lib/
+       install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(1)/usr/lib/ebtables/
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/ebtables $(1)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(1)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(1)/usr/sbin/
+endef
 
 $(eval $(call BuildPackage,ebtables))