[package] gdb: fix debugging of MIPS(el) applications
[openwrt.git] / package / e2fsprogs / Makefile
index 692e745..ebc21c9 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.42.3
-PKG_MD5SUM:=73431146f58d40fe1375aba2060f0da8
+PKG_VERSION:=1.42.4
+PKG_MD5SUM:=b6e296f210d642361b7394437ff0f318
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -30,17 +30,18 @@ $(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Ext2/3/4 filesystem utilities
-  DEPENDS:=+libblkid +libuuid +libext2fs +libpthread +libcom_err
+  DEPENDS:=+libblkid +libuuid +libext2fs
 endef
 
 define Package/e2fsprogs/description
  This package contains essential ext2 filesystem utilities which consists of
- e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2
+ e2fsck, mke2fs, tune2fs, and most of the other core ext2
  filesystem utilities.
 endef
 
 define Package/libext2fs
 $(call Package/e2fsprogs/Default)
+  DEPENDS:=+libcom_err
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=ext2/3/4 filesystem library
@@ -52,6 +53,7 @@ endef
 
 define Package/libcom_err
 $(call Package/e2fsprogs/Default)
+  DEPENDS:=+libpthread
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Common error description library