[package/busybox]: we don't support gcc 4.5.0
[openwrt.git] / package / busybox / Makefile
index c61e3f4..d30be0d 100644 (file)
@@ -9,7 +9,8 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.17.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
+PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
@@ -62,10 +63,6 @@ ifdef CONFIG_GCC_VERSION_LLVM
   TARGET_CFLAGS += -fnested-functions
 endif
 
-ifdef CONFIG_GCC_VERSION_4_5_0
-  TARGET_CFLAGS += -fno-tree-pta
-endif
-
 define Build/Compile
        $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \