busybox: fix configured stampfile name - add $(SH_FUNC) for md5s
[openwrt.git] / package / busybox / Makefile
index 3968f18..c61e3f4 100644 (file)
@@ -1,44 +1,98 @@
-# $Id$
+# 
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.1.3
+PKG_VERSION:=1.17.3
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.busybox.net/downloads
-PKG_MD5SUM:=19a0b475169335f17e421cf644616fe7
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=http://www.busybox.net/downloads \
+               http://distfiles.gentoo.org/distfiles/
+PKG_MD5SUM:=a2ce1a951571da8c6e0eaf75b1acef60
 
-include $(TOPDIR)/package/rules.mk
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+ifeq ($(DUMP),)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+endif
+
+init-y :=
+init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
+init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
+init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 
 define Package/busybox
-SECTION:=base
-CATEGORY:=Base system
-MENU:=1
-DEFAULT:=y
-TITLE:=Core utilities for embedded Linux
-DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
-It slices, it dices, it makes Julian Fries.
-URL:=http://busybox.net/
-CONFIG:=\\\
-       menu "Configuration" \\\
-               depends on PACKAGE_busybox \\\
-               source "$(SOURCE)/config/Config.in" \\\
-       endmenu
+  SECTION:=base
+  CATEGORY:=Base system
+  MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+  TITLE:=Core utilities for embedded Linux
+  URL:=http://busybox.net/
+  MENU:=1
+endef
+
+define Package/busybox/description
+ The Swiss Army Knife of embedded Linux.
+ It slices, it dices, it makes Julian Fries.
+endef
+
+define Package/busybox/config
+       source "$(SOURCE)/Config.in"
 endef
 
 define Build/Configure
-       $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
-       yes '' | $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" -C $(PKG_BUILD_DIR) oldconfig
+       rm -f $(PKG_BUILD_DIR)/.configured*
+       grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
+       yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               KBUILD_HAVE_NLS=no \
+               ARCH="$(ARCH)" \
+               oldconfig
+endef
+
+ifdef CONFIG_GCC_VERSION_LLVM
+  TARGET_CFLAGS += -fnested-functions
+endif
+
+ifdef CONFIG_GCC_VERSION_4_5_0
+  TARGET_CFLAGS += -fno-tree-pta
+endif
+
+define Build/Compile
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               KBUILD_HAVE_NLS=no \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               ARCH="$(ARCH)" \
+               SKIP_STRIP=y \
+               all
+       rm -rf $(PKG_INSTALL_DIR)
+       $(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               ARCH="$(ARCH)" \
+               CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
+               install
 endef
 
 define Package/busybox/install
-       $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(1)" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
-       rmdir $(1)/lib64
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       for tmp in $(init-y); do \
+               $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
+       done
+       -rm -rf $(1)/lib64
 endef
 
 $(eval $(call BuildPackage,busybox))