[package] busybox: enable ps wide flag by default
[openwrt.git] / package / busybox / Makefile
index d30be0d..41e7d40 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.17.3
-PKG_RELEASE:=2
+PKG_VERSION:=1.19.3
+PKG_RELEASE:=10
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=a2ce1a951571da8c6e0eaf75b1acef60
+PKG_MD5SUM:=c3938e1ac59602387009bbf1dd1af7f6
 
+PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -36,6 +37,7 @@ define Package/busybox
   MAINTAINER:=Nicolas Thill <nico@openwrt.org>
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
+  DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc
   MENU:=1
 endef
 
@@ -63,6 +65,13 @@ ifdef CONFIG_GCC_VERSION_LLVM
   TARGET_CFLAGS += -fnested-functions
 endif
 
+LDLIBS:=m crypt
+ifdef CONFIG_BUSYBOX_USE_LIBRPC
+  TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+  export LDFLAGS=$(TARGET_LDFLAGS)
+  LDLIBS += rpc
+endif
+
 define Build/Compile
        $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
@@ -71,6 +80,7 @@ define Build/Compile
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
                SKIP_STRIP=y \
+               LDLIBS="$(LDLIBS)" \
                all
        rm -rf $(PKG_INSTALL_DIR)
        $(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -80,6 +90,7 @@ define Build/Compile
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
                CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
+               LDLIBS="$(LDLIBS)" \
                install
 endef