add support for Package/<pkgname>/description - old format still supported, but depre...
[openwrt.git] / package / busybox / Makefile
index 9e30492..05174a3 100644 (file)
@@ -26,15 +26,19 @@ define Package/busybox
   CATEGORY:=Base system
   DEFAULT:=y
   TITLE:=Core utilities for embedded Linux
-  DESCRIPTION:=\
-       The Swiss Army Knife of embedded Linux. \\\
-       It slices, it dices, it makes Julian Fries.
   URL:=http://busybox.net/
   MENU:=1
-  CONFIG:=\\\
-       menu "Configuration" \\\
-               depends on PACKAGE_busybox \\\
-               source "$(SOURCE)/config/Config.in" \\\
+endef
+
+define Package/busybox/description
+The Swiss Army Knife of embedded Linux.
+       It slices, it dices, it makes Julian Fries.
+endef
+
+define Package/busybox/config
+       menu "Configuration"
+               depends on PACKAGE_busybox
+               source "$(SOURCE)/config/Config.in"
        endmenu
 endef
 
@@ -46,11 +50,21 @@ define Build/Configure
                oldconfig
 endef
 
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CROSS="$(TARGET_CROSS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               IPKG_ARCH="$(ARCH)" \
+               all
+endef
+
 define Package/busybox/install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               IPKG_ARCH="$(ARCH)" \
                PREFIX="$(1)" \
                install
        -rm -rf $(1)/lib64