Depend on lantiq board
[openwrt.git] / package / boot / uboot-lantiq / Makefile
index b3d9173..f215eee 100644 (file)
@@ -8,17 +8,23 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2013.01
+PKG_VERSION:=2013.10
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=e58a8a7f78972248190d83de0dc362ce
+PKG_SOURCE_URL:= \
+       http://mirror2.openwrt.org/sources \
+       ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
 PKG_TARGETS:=bin
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
+PKG_BUILD_PARALLEL:=1
+
+FIRMWARE_LANTIQ_SOURCE:=$(TOPDIR)/target/linux/lantiq/files/firmware/lantiq
+
 include $(INCLUDE_DIR)/package.mk
 
 define uboot/Default
@@ -26,51 +32,194 @@ define uboot/Default
   SOC:=
   DDR_SETTINGS:=
   IMAGE:=
+  DEPS:=
 endef
 
 define uboot/arv4519pw_ram
   TITLE:=U-Boot for Arcadyan arv4519pw (RAM)
   SOC:=danube
   DDR_SETTINGS:=board/arcadyan/arv4519pw/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_ARV4519PW
 endef
 
 define uboot/arv4519pw_nor
   TITLE:=U-Boot for Arcadyan arv4519pw (NOR)
   SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV4519PW
+endef
+
+define uboot/arv4519pw_brn
+  TITLE:=U-Boot for Arcadyan arv4519pw (BRN)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV4519PW
+endef
+
+define uboot/arv7510pw_ram
+  TITLE:=U-Boot for Arcadyan arv7510pw (RAM)
+  SOC:=danube
+  DDR_SETTINGS:=board/arcadyan/arv7510pw/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_ARV4510PW
+endef
+
+define uboot/arv7510pw_nor
+  TITLE:=U-Boot for Arcadyan arv7510pw (NOR)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV4510PW
+endef
+
+define uboot/arv7510pw_brn
+  TITLE:=U-Boot for Arcadyan arv7510pw (BRN)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV4510PW
 endef
 
 define uboot/arv7518pw_ram
   TITLE:=U-Boot for Arcadyan arv7518pw (RAM)
   SOC:=danube
   DDR_SETTINGS:=board/arcadyan/arv7518pw/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_ARV7518PW
 endef
 
 define uboot/arv7518pw_nor
   TITLE:=U-Boot for Arcadyan arv7518pw (NOR)
   SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV7518PW
+endef
+
+define uboot/arv7518pw_brn
+  TITLE:=U-Boot for Arcadyan arv7518pw (BRN)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV7518PW
+endef
+
+define uboot/arv752dpw_ram
+  TITLE:=U-Boot for Arcadyan arv752dpw (RAM)
+  SOC:=danube
+  DDR_SETTINGS:=board/arcadyan/arv752dpw/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_ARV752DPW
+endef
+
+define uboot/arv752dpw_nor
+  TITLE:=U-Boot for Arcadyan arv752dpw (NOR)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV752DPW
+endef
+
+define uboot/arv752dpw_brn
+  TITLE:=U-Boot for Arcadyan arv752dpw (BRN)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV752DPW
+endef
+
+define uboot/arv752dpw22_ram
+  TITLE:=U-Boot for Arcadyan arv752dpw22 (RAM)
+  SOC:=danube
+  DDR_SETTINGS:=board/arcadyan/arv752dpw22/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_ARV752DPW22
+endef
+
+define uboot/arv752dpw22_nor
+  TITLE:=U-Boot for Arcadyan arv752dpw22 (NOR)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV752DPW22
+endef
+
+define uboot/arv752dpw22_brn
+  TITLE:=U-Boot for Arcadyan arv752dpw22 (BRN)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ARV752DPW22
 endef
 
 define uboot/gigasx76x_ram
   TITLE:=U-Boot for Siemens Gigaset sx76x (RAM)
   SOC:=danube
   DDR_SETTINGS:=board/gigaset/sx76x/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_GIGASX76X
 endef
 
 define uboot/gigasx76x_nor
   TITLE:=U-Boot for Siemens Gigaset sx76x (NOR)
   SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_GIGASX76X
+endef
+
+define uboot/acmp252_ram
+  TITLE:=U-Boot for AudioCodes MP-252 (RAM)
+  SOC:=danube
+  DDR_SETTINGS:=board/audiocodes/acmp252/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_ACMP252
+endef
+
+define uboot/acmp252_nor
+  TITLE:=U-Boot for AudioCodes MP-252 (NOR)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_ACMP252
+endef
+
+define uboot/easy50712_ram
+  TITLE:=U-Boot for Lantiq EASY50712 (RAM)
+  SOC:=danube
+  DDR_SETTINGS:=board/lantiq/easy50712/ddr_settings.h
+  DEPS:=@TARGET_lantiq_xway_EASY50712
 endef
 
+define uboot/easy50712_nor
+  TITLE:=U-Boot for Lantiq EASY50712 (NOR)
+  SOC:=danube
+  DEPS:=@TARGET_lantiq_xway_EASY50712
+endef
+
+define uboot/easy50712_norspl
+  TITLE:=U-Boot for Lantiq EASY50712 (NOR SPL)
+  SOC:=danube
+  IMAGE:=u-boot.ltq.lzo.norspl
+  DEPS:=@TARGET_lantiq_xway_EASY50712
+endef
+
+define uboot/easy80920_ram
+  TITLE:=U-Boot for Lantiq EASY80920 (RAM)
+  SOC:=vr9
+  DDR_SETTINGS:=board/lantiq/easy80920/ddr_settings.h
+  DEPS:=@(TARGET_lantiq_xrx200_EASY80920NOR||TARGET_lantiq_xrx200_EASY80920NAND)
+endef
+
+define uboot/easy80920_nor
+  TITLE:=U-Boot for Lantiq EASY80920 (NOR)
+  SOC:=vr9
+  DEPS:=@(TARGET_lantiq_xrx200_EASY80920NOR||TARGET_lantiq_xrx200_EASY80920NAND)
+endef
+
+define uboot/easy80920_norspl
+  TITLE:=U-Boot for Lantiq EASY80920 (NOR SPL)
+  SOC:=vr9
+  IMAGE:=u-boot.ltq.lzo.norspl
+  DEPS:=@(TARGET_lantiq_xrx200_EASY80920NOR||TARGET_lantiq_xrx200_EASY80920NAND)
+endef
+
+define uboot/easy80920_sfspl
+  TITLE:=U-Boot for Lantiq EASY80920 (SPI SPL)
+  SOC:=vr9
+  IMAGE:=u-boot.ltq.lzo.sfspl
+  DEPS:=@(TARGET_lantiq_xrx200_EASY80920NOR||TARGET_lantiq_xrx200_EASY80920NAND)
+endef
+
+
 UBOOTS:= \
-       arv4519pw_ram arv4519pw_nor \
-       arv7518pw_ram arv7518pw_nor \
-       gigasx76x_ram gigasx76x_nor
+       arv4519pw_ram arv4519pw_nor arv4519pw_brn \
+       arv7510pw_ram arv7510pw_nor arv7510pw_brn \
+       arv7518pw_ram arv7518pw_nor arv7518pw_brn \
+       arv752dpw_ram arv752dpw_nor arv752dpw_brn \
+       arv752dpw22_ram arv752dpw22_nor arv752dpw22_brn \
+       gigasx76x_ram gigasx76x_nor \
+       acmp252_ram acmp252_nor \
+       easy50712_ram easy50712_nor easy50712_norspl \
+       easy80920_ram easy80920_nor easy80920_norspl easy80920_sfspl
 
 define Package/uboot/template
 define Package/uboot-lantiq-$(1)
   SECTION:=boot
   CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_lantiq_xway
+  DEPENDS:=$(3)
   TITLE:=$(2)
   URL:=http://www.denx.de/wiki/U-Boot
   VARIANT:=$(1)
@@ -81,7 +230,21 @@ endef
 define BuildUBootPackage
        $(eval $(uboot/Default))
        $(eval $(uboot/$(1)))
-       $(call Package/uboot/template,$(1),$(TITLE))
+       DEPS:=$(uboot/$(1)/DEPS)
+       $(call Package/uboot/template,$(1),$(TITLE),$(DEPS))
+endef
+
+define CopyVR9Firmware
+       $(CP) $(FIRMWARE_LANTIQ_SOURCE)/vr9_phy$(1)_a$(2)x.bin \
+               $(PKG_BUILD_DIR)/arch/mips/cpu/mips32/vrx200/fw_phy$(1)_a$(2)x.blob
+endef
+
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(call CopyVR9Firmware,11g,1)
+       $(call CopyVR9Firmware,11g,2)
+       $(call CopyVR9Firmware,22f,1)
+       $(call CopyVR9Firmware,22f,2)
 endef
 
 define Build/Configure