package/base-files: enhance & cleanup service wrappers
[openwrt.git] / package / base-files / Makefile
index b7fb073..6e41f04 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=66
+PKG_RELEASE:=91
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
@@ -34,6 +34,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
+  DEPENDS:=+!USE_NETIFD:base-files-network +USE_NETIFD:netifd
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -57,6 +58,7 @@ define Package/base-files/conffiles
 /etc/sysupgrade.conf
 /etc/config/
 /etc/dropbear/
+/etc/crontabs/
 $(call $(TARGET)/conffiles)
 endef
 
@@ -64,6 +66,11 @@ define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
+define Package/base-files/config
+  config USE_NETIFD
+    bool "Use netifd instead of the old network init scripts (experimental!)"
+       default n
+endef
 
 define Package/gcc/Default
   SECTION:=libs
@@ -246,6 +253,32 @@ define Package/librt/config
 endef
 
 
+define Package/libgfortran
+$(call Package/gcc/Default)
+  TITLE:=GFortran support library
+  DEPENDS+=@!(TARGET_avr32||TARGET_coldfire) @INSTALL_GFORTRAN
+endef
+
+define Package/libgfortran/config
+       menu "Configuration"
+               depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+
+       config LIBGFORTRAN_ROOT_DIR
+               string
+               prompt "libgfortran shared library base directory"
+               depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+               default TOOLCHAIN_ROOT  if !NATIVE_TOOLCHAIN
+               default "/"  if NATIVE_TOOLCHAIN
+
+       config LIBGFORTRAN_FILE_SPEC
+               string
+               prompt "libgfortran shared library files (use wildcards)"
+               depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+               default "./usr/lib/libgfortran.so.*"
+
+       endmenu
+endef
+
 define Package/ldd
 $(call Package/libc/Default)
   SECTION:=utils
@@ -362,7 +395,7 @@ ifneq ($(BUILD_LIBGCC),)
                "$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread_so.a)" \
                "$(patsubst $(TOOLCHAIN_DIR)/lib/%,$(PKG_BUILD_DIR)/%,$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread-*.so))" \
                -Wl,-z,nodelete,-z,initfirst,-init=__pthread_initialize_minimal_internal \
-               -ldl $(BUILD_LIBGCC) \
+               -ldl -lc $(BUILD_LIBGCC) \
                -Wl,-soname=libpthread.so.0
   endef
   define Build/Compile/libgcc
@@ -462,7 +495,12 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   define Package/libgcc/install
        $(INSTALL_DIR) $(1)/lib
-       $(CP) $(PKG_BUILD_DIR)/libgcc_s.so.* $(1)/lib/
+       $(CP) $(TOOLCHAIN_DIR)/lib/libgcc_s.so.* $(1)/lib/
+  endef
+
+  define Package/libgfortran/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(TOOLCHAIN_DIR)/lib/libgfortran.so.* $(1)/usr/lib/
   endef
 
   define Package/libssp/install
@@ -481,16 +519,19 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   define Package/glibc/install
        $(CP) ./glibc-files/* $(1)/
+       rm -f $(1)/etc/localtime
+       ln -sf /tmp/localtime $(1)/etc/localtime
        $(INSTALL_DIR) $(1)/lib
        $(CP) \
                $(TOOLCHAIN_DIR)/lib/ld*.so.* \
                $(TOOLCHAIN_DIR)/lib/ld-$(LIBC_SO_VERSION).so \
                $(1)/lib/
        for file in libanl libc libcidn libcrypt libdl libm $(use_libnsl) $(use_nsswitch) libresolv $(use_libutil); do \
-               $(CP) \
-                       $(TOOLCHAIN_DIR)/lib/$$$$file.so.* \
-                       $(TOOLCHAIN_DIR)/lib/$$$$file-$(LIBC_SO_VERSION).so \
-                       $(1)/lib/; \
+               for file in $(TOOLCHAIN_DIR)/lib/$$$$file.so.* $(TOOLCHAIN_DIR)/lib/$$$$file-$(LIBC_SO_VERSION).so; do \
+                       if [ -e "$$$$file" ]; then \
+                               $(CP) $$$$file $(1)/lib/; \
+                       fi; \
+               done; \
        done
   endef
 
@@ -575,6 +616,15 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LIBGCC_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
+       done ; \
+       exit 0
+  endef
+
+  define Package/libgfortran/install
+       for file in $(call qstrip,$(CONFIG_LIBGFORTRAN_FILE_SPEC)); do \
+               dir=`dirname $$$$file` ; \
+               $(INSTALL_DIR) $(1)/$$$$dir ; \
+               $(CP) $(call qstrip,$(CONFIG_LIBGFORTRAN_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
        done
   endef
 
@@ -583,7 +633,8 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LIBSSP_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
-       done
+       done ; \
+       exit 0
   endef
 
   define Package/libstdcpp/install
@@ -591,7 +642,8 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LIBSTDCPP_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
-       done
+       done ; \
+       exit 0
   endef
 
   define Package/libc/install
@@ -599,7 +651,8 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LIBC_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
-       done
+       done ; \
+       exit 0
   endef
 
   define Package/libpthread/install
@@ -607,7 +660,8 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LIBPTHREAD_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
-       done
+       done ; \
+       exit 0
   endef
 
   define Package/librt/install
@@ -615,7 +669,8 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LIBRT_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
-       done
+       done ; \
+       exit 0
   endef
 
   define Package/ldd/install
@@ -623,7 +678,8 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LDD_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
-       done
+       done ; \
+       exit 0
   endef
 
   define Package/ldconfig/install
@@ -631,7 +687,8 @@ else
                dir=`dirname $$$$file` ; \
                $(INSTALL_DIR) $(1)/$$$$dir ; \
                $(CP) $(call qstrip,$(CONFIG_LDCONFIG_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
-       done
+       done ; \
+       exit 0
   endef
 
 endif
@@ -647,5 +704,6 @@ $(eval $(call BuildPackage,libssp))
 $(eval $(call BuildPackage,libstdcpp))
 $(eval $(call BuildPackage,libpthread))
 $(eval $(call BuildPackage,librt))
+$(eval $(call BuildPackage,libgfortran))
 $(eval $(call BuildPackage,ldd))
 $(eval $(call BuildPackage,ldconfig))