[package] base-files: add network_get_device() to network.sh
[openwrt.git] / package / base-files / Makefile
index 892a317..4e9b41f 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=106
+PKG_RELEASE:=108
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
@@ -35,7 +35,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+!USE_NETIFD:base-files-network +USE_NETIFD:netifd
+  DEPENDS:=+DISABLE_NETIFD:base-files-network +!DISABLE_NETIFD:netifd
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -63,8 +63,8 @@ define Package/base-files/description
 endef
 
 define Package/base-files/config
-  config USE_NETIFD
-    bool "Use netifd instead of the old network init scripts (experimental!)"
+  config DISABLE_NETIFD
+    bool "Use the old (deprecated) network init scripts instead of netifd"
        default n
 endef
 
@@ -512,12 +512,12 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
        $(CP) $(TOOLCHAIN_DIR)/lib/libstdc++.so.* $(1)/usr/lib/
   endef
 
-  use_libutil=$(if $(CONFIG_USE_GLIBC)$(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),libutil)
-  use_libnsl=$(if $(CONFIG_USE_GLIBC)$(CONFIG_EGLIBC_OPTION_EGLIBC_NIS),libnsl)
-  use_nsswitch=$(if $(CONFIG_USE_GLIBC)$(CONFIG_EGLIBC_OPTION_EGLIBC_NSSWITCH),libnss_dns libnss_files)
+  use_libutil=$(if $(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),libutil)
+  use_libnsl=$(if $(CONFIG_EGLIBC_OPTION_EGLIBC_NIS),libnsl)
+  use_nsswitch=$(if $(CONFIG_EGLIBC_OPTION_EGLIBC_NSSWITCH),libnss_dns libnss_files)
 
-  define Package/glibc/install
-       $(CP) ./glibc-files/* $(1)/
+  define Package/eglibc/install
+       $(CP) ./eglibc-files/* $(1)/
        rm -f $(1)/etc/localtime
        ln -sf /tmp/localtime $(1)/etc/localtime
        $(INSTALL_DIR) $(1)/lib
@@ -534,10 +534,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
        done
   endef
 
-  define Package/eglibc/install
-    $(call Package/glibc/install,$1)
-  endef
-
   define Package/uClibc/install
        $(INSTALL_DIR) $(1)/lib
        $(CP) \